commit 9f1fdd9af4b1ce2a8ce1f7fe22dfc9d3e3a9ff0b
parent ed5811e54f7ef23a0d3f86172297b30348d7f2f3
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Sat, 2 Oct 2021 22:57:41 +0300
Add gpxeditor
Diffstat:
2 files changed, 38 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -219,6 +219,7 @@ lib.makeScope newScope (
gpx-layer = perlPackages.callPackage ./gpx/gpx-layer { };
gpx2yaml = callPackage ./gpx/gpx2yaml { };
gpxchart = callPackage ./gpx/gpxchart { };
+ gpxeditor = callPackage ./gpx/gpxeditor { };
gpxlib = callPackage ./gpx/gpxlib { };
gpxsee-bin = callPackage ./gpx/gpxsee/bin.nix { };
gpxtools = callPackage ./gpx/gpxtools { };
diff --git a/pkgs/gpx/gpxeditor/default.nix b/pkgs/gpx/gpxeditor/default.nix
@@ -0,0 +1,37 @@
+{ lib, stdenv, fetchurl, unzip, wine, writers }:
+let
+ runScript = writers.writeBash "gpxeditor" ''
+ export WINEDEBUG=warn+all
+ ${wine}/bin/wine @out@/GPX_Editor.exe
+ '';
+in
+stdenv.mkDerivation rec {
+ pname = "gpxeditor";
+ version = "1.7.15";
+
+ src = fetchurl {
+ url = "mirror://sourceforge/gpxeditor/GPX%20Editor/Version%20${version}/GPX_Editor_${lib.replaceStrings [ "." ] [ "_" ] version}.zip";
+ hash = "sha256-laGJU8LHNNoUoVyHY2IaCXGpFmgOLSrWe/lCz5Tzjj4=";
+ };
+
+ dontUnpack = true;
+
+ installPhase = ''
+ install -dm755 $out/bin
+ substitute ${runScript} $out/bin/gpxeditor --subst-var out
+ chmod +x $out/bin/gpxeditor
+
+ ${unzip}/bin/unzip $src -d $out
+ '';
+
+ preferLocalBuild = true;
+
+ meta = with lib; {
+ description = "Load, modify and save your GPX files";
+ homepage = "https://sourceforge.net/projects/gpxeditor/";
+ license = licenses.gpl2;
+ maintainers = [ maintainers.sikmir ];
+ platforms = platforms.all;
+ skip.ci = true;
+ };
+}