commit 9e770982a4f5f16e79a80017528bb9b18acf5dd5
parent b5e9b31ad914f81b814b5bf90ca53d31c4c54df1
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Thu, 25 Jan 2024 18:51:03 +0400
Up
Diffstat:
6 files changed, 24 insertions(+), 47 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -192,7 +192,6 @@ lib.makeScope newScope (
### GEOSPATIAL
- apispec-webframeworks = callPackage ./geospatial/apispec-webframeworks { };
arcgis2geojson = callPackage ./geospatial/arcgis2geojson { };
c2cwsgiutils = callPackage ./geospatial/c2cwsgiutils { };
cogdumper = callPackage ./geospatial/cogdumper { };
diff --git a/pkgs/geospatial/apispec-webframeworks/default.nix b/pkgs/geospatial/apispec-webframeworks/default.nix
@@ -1,34 +0,0 @@
-{ lib, python3Packages }:
-
-python3Packages.buildPythonPackage rec {
- pname = "apispec-webframeworks";
- version = "0.5.2";
- disabled = python3Packages.pythonOlder "3.6";
-
- src = python3Packages.fetchPypi {
- inherit pname version;
- hash = "sha256-DbNbJnkUs/jFYqygJhlX28tBdvJV6swiUgJ3AQgY3PM=";
- };
-
- propagatedBuildInputs = with python3Packages; [
- apispec
- pyyaml
- ];
-
- nativeCheckInputs = with python3Packages; [
- pytestCheckHook
- mock
- flask
- tornado
- bottle
- ];
-
- pythonImportsCheck = [ "apispec_webframeworks" ];
-
- meta = with lib; {
- description = "apispec plugin for integrating with various web frameworks";
- homepage = "https://github.com/marshmallow-code/apispec-webframeworks";
- license = licenses.mit;
- maintainers = [ maintainers.sikmir ];
- };
-}
diff --git a/pkgs/geospatial/morecantile/default.nix b/pkgs/geospatial/morecantile/default.nix
@@ -2,19 +2,22 @@
python3Packages.buildPythonPackage rec {
pname = "morecantile";
- version = "3.1.2";
- disabled = python3Packages.pythonOlder "3.6";
+ version = "5.2.2";
+ pyproject = true;
+ disabled = python3Packages.pythonOlder "3.8";
src = fetchFromGitHub {
owner = "developmentseed";
repo = "morecantile";
rev = version;
- hash = "sha256-QvqXpcjunRWzfdcoyt3pUulDd20Ga8Cs9NTeLnUf5c8=";
+ hash = "sha256-Y0KUsI0OjkgEjEJsMTwchcQG0LEOEzj7YwN5F+eUb8I=";
};
+ nativeBuildInputs = with python3Packages; [ flit ];
+
propagatedBuildInputs = with python3Packages; [ attrs pydantic pyproj ];
- nativeCheckInputs = with python3Packages; [ mercantile pytestCheckHook ];
+ nativeCheckInputs = with python3Packages; [ mercantile pytestCheckHook rasterio ];
passthru.tests.version = testers.testVersion {
package = morecantile;
diff --git a/pkgs/geospatial/pysheds/default.nix b/pkgs/geospatial/pysheds/default.nix
@@ -2,13 +2,13 @@
python3Packages.buildPythonPackage rec {
pname = "pysheds";
- version = "0.3.3";
+ version = "0.3.5";
src = fetchFromGitHub {
owner = "mdbartos";
repo = "pysheds";
rev = version;
- hash = "sha256-p3m4FLj8nOh6EWXUqhqvc3jGwjR8/tr/ULyx6WSiAl0=";
+ hash = "sha256-OAc/OxqEvASpRNJL/KcE+exHGJie0oVv4fS+XXhtRcI=";
};
propagatedBuildInputs = with python3Packages; [
diff --git a/pkgs/geospatial/pystac/default.nix b/pkgs/geospatial/pystac/default.nix
@@ -2,22 +2,31 @@
python3Packages.buildPythonPackage rec {
pname = "pystac";
- version = "1.4.0";
+ version = "1.9.0";
+ pyproject = true;
src = fetchFromGitHub {
owner = "stac-utils";
repo = "pystac";
rev = "v${version}";
- hash = "sha256-khhiCUNiaxC744J+fZiJOXruNILOXvAwe3UNygr2M8U=";
+ hash = "sha256-LbHeEA/F96nVejsNVMR/zrIgIyrBxHiinHcLzk68uA0=";
};
+ nativeBuildInputs = with python3Packages; [ setuptools ];
+
propagatedBuildInputs = with python3Packages; [
python-dateutil
];
- doCheck = false;
-
- nativeCheckInputs = with python3Packages; [ jsonschema pytestCheckHook ];
+ nativeCheckInputs = with python3Packages; [
+ html5lib
+ jsonschema
+ pytestCheckHook
+ pytest-cov
+ pytest-mock
+ pytest-recording
+ requests-mock
+ ];
pythonImportsCheck = [ "pystac" ];
diff --git a/pkgs/geospatial/terracotta/default.nix b/pkgs/geospatial/terracotta/default.nix
@@ -1,4 +1,4 @@
-{ lib, fetchFromGitHub, python3Packages, apispec-webframeworks }:
+{ lib, fetchFromGitHub, python3Packages }:
python3Packages.buildPythonApplication rec {
pname = "terracotta";