commit 9e70549ac66d7857705a2ba44bff6954066dea9a
parent b2b52b081bc62d4d19f421d67741015133f77559
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Thu, 18 Aug 2022 09:55:47 +0300
Move o to nixpkgs
Diffstat:
2 files changed, 0 insertions(+), 40 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -323,7 +323,6 @@ lib.makeScope newScope (
};
nanodns = callPackage ./misc/nanodns { };
nmtree = callPackage ./misc/nmtree { };
- o = callPackage ./misc/o { };
objlab = callPackage ./misc/objlab { };
playonmac = callPackage ./misc/playonmac { };
pnoise = callPackage ./misc/pnoise { };
diff --git a/pkgs/misc/o/default.nix b/pkgs/misc/o/default.nix
@@ -1,39 +0,0 @@
-{ lib, stdenv, buildGoModule, fetchFromGitHub, installShellFiles, makeWrapper, pkg-config
-, withGui ? stdenv.isLinux, vte # vte is broken on darwin
-}:
-
-buildGoModule rec {
- pname = "o";
- version = "2.55.1";
-
- src = fetchFromGitHub {
- owner = "xyproto";
- repo = "o";
- rev = "v${version}";
- hash = "sha256-owueLd6kR/bDFxKI9QOUgriH63XRsEEpIFfp5aRTSbI=";
- };
-
- vendorSha256 = null;
-
- nativeBuildInputs = [ installShellFiles makeWrapper pkg-config ];
-
- buildInputs = lib.optional withGui vte;
-
- preBuild = "cd v2";
-
- postInstall = ''
- cd ..
- installManPage o.1
- '' + lib.optionalString withGui ''
- make install-gui PREFIX=$out
- wrapProgram $out/bin/ko --prefix PATH : $out/bin
- '';
-
- meta = with lib; {
- description = "Config-free text editor and IDE limited to VT100";
- inherit (src.meta) homepage;
- license = licenses.bsd3;
- maintainers = [ maintainers.sikmir ];
- platforms = platforms.unix;
- };
-}