commit 9be43c719244569f8ac4b4005c4d38f2a1e5b34c
parent 24320cccacb4626797c8e3d4a5477c166b0de0d8
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Sat, 8 May 2021 02:08:59 +0300
wikitextprocessor: fix on darwin
Diffstat:
1 file changed, 6 insertions(+), 1 deletion(-)
diff --git a/pkgs/development/python-modules/wikitextprocessor/default.nix b/pkgs/development/python-modules/wikitextprocessor/default.nix
@@ -1,4 +1,4 @@
-{ lib, python3Packages, fetchFromGitHub, lru-dict }:
+{ lib, stdenv, python3Packages, fetchFromGitHub, lru-dict }:
python3Packages.buildPythonApplication rec {
pname = "wikitextprocessor";
@@ -15,6 +15,11 @@ python3Packages.buildPythonApplication rec {
checkInputs = with python3Packages; [ pytestCheckHook ];
+ disabledTests = lib.optionals stdenv.isDarwin [
+ "test_long_twothread"
+ "test_expr29"
+ ];
+
meta = with lib; {
description = "Parser and expander for Wikipedia, Wiktionary etc. dump files, with Lua execution support";
inherit (src.meta) homepage;