commit 9b2bf2b195484cde91d5c863c771fa6ad27a3680
parent a53fde5ff25a83faf8cd4d8235fb518ad9e7056b
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Thu, 13 Feb 2020 10:07:02 +0300
Update platforms
Diffstat:
3 files changed, 17 insertions(+), 5 deletions(-)
diff --git a/pkgs/applications/gpxlab/default.nix b/pkgs/applications/gpxlab/default.nix
@@ -1,4 +1,4 @@
-{ mkDerivation, lib, qmake, qtbase, qttools, qttranslations, sources }:
+{ stdenv, mkDerivation, lib, qmake, qtbase, qttools, qttranslations, sources }:
mkDerivation rec {
pname = "gpxlab";
@@ -12,12 +12,18 @@ mkDerivation rec {
lrelease GPXLab/locale/*.ts
'';
+ postInstall = lib.optionalString stdenv.isDarwin ''
+ mkdir -p $out/Applications
+ mv GPXLab/GPXLab.app $out/Applications
+ wrapQtApp $out/Applications/GPXLab.app/Contents/MacOS/GPXLab
+ '';
+
enableParallelBuilding = true;
meta = with lib; {
inherit (src) description homepage;
license = licenses.gpl3;
maintainers = with maintainers; [ sikmir ];
- platforms = platforms.linux;
+ platforms = with platforms; linux ++ darwin;
};
}
diff --git a/pkgs/applications/gpxsee/default.nix b/pkgs/applications/gpxsee/default.nix
@@ -1,4 +1,4 @@
-{ mkDerivation, lib, qmake, qtbase, qttools, qttranslations, sources }:
+{ stdenv, mkDerivation, lib, qmake, qtbase, qttools, qttranslations, sources }:
mkDerivation rec {
pname = "gpxsee";
@@ -12,12 +12,18 @@ mkDerivation rec {
lrelease lang/*.ts
'';
+ postInstall = lib.optionalString stdenv.isDarwin ''
+ mkdir -p $out/Applications
+ mv GPXSee.app $out/Applications
+ wrapQtApp $out/Applications/GPXSee.app/Contents/MacOS/GPXSee
+ '';
+
enableParallelBuilding = true;
meta = with lib; {
inherit (src) description homepage;
license = licenses.gpl3;
maintainers = with maintainers; [ sikmir ];
- platforms = platforms.linux;
+ platforms = with platforms; linux ++ darwin;
};
}
diff --git a/pkgs/tools/gmaptool/default.nix b/pkgs/tools/gmaptool/default.nix
@@ -22,6 +22,6 @@ stdenv.mkDerivation rec {
homepage = "https://www.gmaptool.eu";
license = licenses.cc-by-sa-30;
maintainers = with maintainers; [ sikmir ];
- platforms = platforms.all;
+ platforms = platforms.linux;
};
}