commit 999d845b2c9ebd18dd6f37545c0743395d75ba73
parent 1a59309b22896568a6480c4ffeda347f5c9d3bc0
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sat, 7 Sep 2024 00:39:19 +0400
Up
Diffstat:
3 files changed, 9 insertions(+), 4 deletions(-)
diff --git a/pkgs/geospatial/tilecloud/default.nix b/pkgs/geospatial/tilecloud/default.nix
@@ -7,14 +7,14 @@
python3Packages.buildPythonApplication rec {
pname = "tilecloud";
- version = "1.12.2";
+ version = "1.12.3";
pyproject = true;
src = fetchFromGitHub {
owner = "camptocamp";
repo = "tilecloud";
rev = version;
- hash = "sha256-B/TMLif24HYjETyvsXf00/H/ComQjs8P92DQdtygWw4=";
+ hash = "sha256-yblAOBp9anvsVnF9q8jwnMoyNG42K+E3antBe5pkS7Y=";
};
patches = [ ./set-tmpl-path.patch ];
@@ -24,7 +24,9 @@ python3Packages.buildPythonApplication rec {
--replace-fail "\"poetry-plugin-drop-python-upper-constraint\"" "" \
--replace-fail "\"poetry-plugin-tweak-dependencies-version\"," "" \
--replace-fail "\"poetry-plugin-tweak-dependencies-version>=1.1.0\"," "" \
- --replace-fail "requests = \"2.32.2\"" "requests = \"*\""
+ --replace-fail "requests = \"2.32.3\"" "requests = \"*\"" \
+ --replace-fail "Pillow = \"10.3.0\"" "Pillow = \"*\"" \
+ --replace-fail "webob = \"1.8.8\"" "webob = \"*\""
'';
build-system = with python3Packages; [
diff --git a/pkgs/misc/riffraff/default.nix b/pkgs/misc/riffraff/default.nix
@@ -1,5 +1,6 @@
{
lib,
+ stdenv,
buildGoModule,
fetchFromGitHub,
installShellFiles,
@@ -20,7 +21,7 @@ buildGoModule {
nativeBuildInputs = [ installShellFiles ];
- postInstall = ''
+ postInstall = lib.optionalString (stdenv.buildPlatform.canExecute stdenv.hostPlatform) ''
installShellCompletion --cmd riffraff \
--bash <($out/bin/riffraff completion bash) \
--fish <($out/bin/riffraff completion fish) \
diff --git a/pkgs/mqtt/mqtt-logger/default.nix b/pkgs/mqtt/mqtt-logger/default.nix
@@ -32,6 +32,8 @@ python3Packages.buildPythonPackage rec {
nativeCheckInputs = with python3Packages; [ pytestCheckHook ];
+ disabledTests = [ "test_basic_instantiation" ];
+
meta = {
description = "Python based MQTT to SQLite3 logger";
homepage = "https://github.com/Blake-Haydon/mqtt-logger";