commit 94fc880f361445ed18905252d80dbd3bf1e1c569
parent ee2086877032085e54c94ae29fb59ec275e90a74
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Fri, 23 Apr 2021 10:56:40 +0300
Move cheetah3 to nixpkgs
Diffstat:
3 files changed, 0 insertions(+), 39 deletions(-)
diff --git a/nix/sources.json b/nix/sources.json
@@ -13,20 +13,6 @@
"url": "https://github.com/ruarxive/apibackuper/archive/1ff139f688d59b899ff041ccc282e224110ddc76.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
},
- "cheetah3": {
- "branch": "master",
- "builtin": false,
- "date": "2021-02-22T10:57:01Z",
- "description": "Cheetah3 is a free (MIT) and open source template engine for Python",
- "homepage": "https://cheetahtemplate.org/",
- "owner": "CheetahTemplate3",
- "repo": "cheetah3",
- "rev": "a4e33f0f55ed5909437cbbf262fa99de78a7ad2b",
- "sha256": "0y7py63fcxk3wk85n87y3kgiq07qyqirbh4r2pd2m1kpyyjzshsc",
- "type": "tarball",
- "url": "https://github.com/CheetahTemplate3/cheetah3/archive/a4e33f0f55ed5909437cbbf262fa99de78a7ad2b.tar.gz",
- "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
- },
"dict2rest": {
"branch": "master",
"builtin": false,
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -96,7 +96,6 @@ lib.makeScope newScope (
cjkwrap = callPackage ./development/python-modules/cjkwrap { };
bson = callPackage ./development/python-modules/bson { };
- cheetah3 = callPackage ./development/python-modules/cheetah3 { };
click-6-7 = callPackage ./development/python-modules/click { };
geotiler = callPackage ./development/python-modules/geotiler { };
gpxelevations = callPackage ./development/python-modules/gpxelevations { };
diff --git a/pkgs/development/python-modules/cheetah3/default.nix b/pkgs/development/python-modules/cheetah3/default.nix
@@ -1,24 +0,0 @@
-{ lib, python3Packages, sources }:
-
-python3Packages.buildPythonPackage {
- pname = "cheetah3-unstable";
- version = lib.substring 0 10 sources.cheetah3.date;
-
- src = sources.cheetah3;
-
- checkInputs = with python3Packages; [ pygments markdown ];
-
- checkPhase = ''
- ${python3Packages.python.interpreter} Cheetah/Tests/Test.py
- '';
-
- doCheck = false;
-
- pythonImportsCheck = [ "Cheetah" ];
-
- meta = with lib; {
- inherit (sources.cheetah3) description homepage;
- license = licenses.mit;
- maintainers = [ maintainers.sikmir ];
- };
-}