commit 92692378eebbac75ec78447e7dfd60a961fe7018
parent 8aeb9fd435737af986947f563701b1ec43aa0394
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Thu, 30 Sep 2021 21:59:09 +0300
Add trackanimation
Diffstat:
3 files changed, 64 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -222,6 +222,7 @@ lib.makeScope newScope (
gpxsee-bin = callPackage ./gpx/gpxsee/bin.nix { };
gpxtools = callPackage ./gpx/gpxtools { };
gpxtrackposter = callPackage ./gpx/gpxtrackposter { };
+ trackanimation = callPackage ./gpx/trackanimation { };
### IMAGES
@@ -296,6 +297,7 @@ lib.makeScope newScope (
overpass-api = callPackage ./osm/overpass-api { };
phyghtmap = callPackage ./osm/phyghtmap { };
sdlmap = callPackage ./osm/sdlmap { };
+ smopy = callPackage ./osm/smopy { };
smrender = callPackage ./osm/smrender { };
taginfo-tools = callPackage ./osm/taginfo-tools { };
tilemaker = callPackage ./osm/tilemaker { };
diff --git a/pkgs/gpx/trackanimation/default.nix b/pkgs/gpx/trackanimation/default.nix
@@ -0,0 +1,33 @@
+{ lib, fetchFromGitHub, python3Packages, smopy }:
+
+python3Packages.buildPythonApplication rec {
+ pname = "trackanimation";
+ version = "1.0.5";
+
+ src = fetchFromGitHub {
+ owner = "JoanMartin";
+ repo = pname;
+ rev = "v${version}";
+ hash = "sha256-fLubRKq+3wQh16xSdqJmNMy4zw83RiSQj8C6jNV4fV8=";
+ };
+
+ propagatedBuildInputs = with python3Packages; [
+ geopy
+ gpxpy
+ pillow
+ matplotlib
+ mplleaflet
+ pandas
+ tqdm
+ smopy
+ ];
+
+ pythonImportsCheck = [ "trackanimation" ];
+
+ meta = with lib; {
+ description = "GPS Track Animation Library";
+ inherit (src.meta) homepage;
+ license = licenses.asl20;
+ maintainers = [ maintainers.sikmir ];
+ };
+}
diff --git a/pkgs/osm/smopy/default.nix b/pkgs/osm/smopy/default.nix
@@ -0,0 +1,29 @@
+{ lib, python3Packages, fetchFromGitHub }:
+
+python3Packages.buildPythonPackage rec {
+ pname = "smopy";
+ version = "0.0.6";
+
+ src = fetchFromGitHub {
+ owner = "rossant";
+ repo = pname;
+ rev = "v${version}";
+ hash = "sha256-QytanQQPIlQTog2tTMAwdFXWbXnU4NaA7Zqh4DXFubY=";
+ };
+
+ propagatedBuildInputs = with python3Packages; [
+ numpy
+ ipython
+ pillow
+ matplotlib
+ ];
+
+ pythonImportsCheck = [ "smopy" ];
+
+ meta = with lib; {
+ description = "OpenStreetMap image tiles in Python";
+ inherit (src.meta) homepage;
+ license = licenses.bsd3;
+ maintainers = [ maintainers.sikmir ];
+ };
+}