commit 90cbd2bde894d7add74ba5894e09d29e8d3a67c2
parent 5b9042f92345b600efb561e4110b9287c503d851
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sat, 25 Feb 2023 00:49:25 +0300
Restore qutebrowser-bin
Diffstat:
2 files changed, 35 insertions(+), 0 deletions(-)
diff --git a/pkgs/darwin/qutebrowser/bin.nix b/pkgs/darwin/qutebrowser/bin.nix
@@ -0,0 +1,34 @@
+{ lib, stdenv, fetchfromgh, undmg }:
+
+stdenv.mkDerivation (finalAttrs: {
+ pname = "qutebrowser-bin";
+ version = "2.5.3";
+
+ src = fetchfromgh {
+ owner = "qutebrowser";
+ repo = "qutebrowser";
+ name = "qutebrowser-${finalAttrs.version}.dmg";
+ hash = "sha256-T3DMZhIuXxI1tDCEi7knu6lscGCVSjU1UW76SaKd1N4=";
+ version = "v${finalAttrs.version}";
+ };
+
+ sourceRoot = ".";
+
+ nativeBuildInputs = [ undmg ];
+
+ installPhase = ''
+ mkdir -p $out/Applications
+ cp -r *.app $out/Applications
+ '';
+
+ preferLocalBuild = true;
+
+ meta = with lib; {
+ description = "A keyboard-driven, vim-like browser";
+ homepage = "https://qutebrowser.org";
+ license = licenses.gpl3Plus;
+ maintainers = [ maintainers.sikmir ];
+ platforms = [ "x86_64-darwin" ];
+ skip.ci = true;
+ };
+})
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -29,6 +29,7 @@ lib.makeScope newScope (
cudatext-bin = callPackage ./darwin/cudatext/bin.nix { };
macpass-bin = callPackage ./darwin/macpass/bin.nix { };
marta-bin = callPackage ./darwin/marta { };
+ qutebrowser-bin = callPackage ./darwin/qutebrowser/bin.nix { };
sloth-bin = callPackage ./darwin/sloth { };
### DATA