commit 9008bc02334113250e5415947b6493597888dbd6
parent 098b64b8b26ab0536c5afdc0434e22902cb0fd2f
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sat, 1 Mar 2025 15:41:42 +0400
Add py-patcher
Diffstat:
2 files changed, 34 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -156,6 +156,7 @@ lib.makeScope newScope (
TreeR
;
};
+ py-patcher = callPackage ./garmin/py-patcher { };
sendmap20 = callPackage ./garmin/sendmap20 { };
### GEMINI
diff --git a/pkgs/garmin/py-patcher/default.nix b/pkgs/garmin/py-patcher/default.nix
@@ -0,0 +1,33 @@
+{
+ lib,
+ fetchFromGitHub,
+ python3Packages,
+}:
+
+python3Packages.buildPythonApplication {
+ pname = "py-patcher";
+ version = "0-unstable-2024-12-13";
+ format = "other";
+
+ src = fetchFromGitHub {
+ owner = "slazav";
+ repo = "py_patcher";
+ rev = "da55892a90eefaabffcf1eae2d6fd8a15ae26e15";
+ hash = "sha256-po4Vg1j6Q65b8+syStegordTndSxJXYXNPigOTpjaUY=";
+ };
+
+ dontUseSetuptoolsBuild = true;
+ dontUseSetuptoolsCheck = true;
+
+ installPhase = ''
+ install -Dm755 patcher.py $out/bin/patcher
+ install -Dm644 patches.txt -t $out/share/py-patcher
+ '';
+
+ meta = {
+ description = "A python version of Garmin firmware patcher";
+ homepage = "https://github.com/slazav/py_patcher";
+ license = lib.licenses.gpl2Only;
+ maintainers = [ lib.maintainers.sikmir ];
+ };
+}