commit 8e4384bad19cedcdb6b1b271952fb0299f209d2a
parent 502f59a411eaf386b7535715b1a3cebc599cfc5b
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Thu, 7 Jul 2022 15:24:12 +0300
Move foma to nixpkgs
Diffstat:
2 files changed, 0 insertions(+), 43 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -264,9 +264,6 @@ lib.makeScope newScope (
dict2rest = callPackage ./linguistics/dict2rest { };
distance = callPackage ./linguistics/distance { };
- foma = callPackage ./linguistics/foma {
- libtool = if pkgs.stdenv.isDarwin then pkgs.darwin.cctools else null;
- };
gdcv = callPackage ./linguistics/gdcv { };
goldendict-bin = callPackage ./linguistics/goldendict/bin.nix { };
gt-bash-client = callPackage ./linguistics/gt-bash-client { };
diff --git a/pkgs/linguistics/foma/default.nix b/pkgs/linguistics/foma/default.nix
@@ -1,40 +0,0 @@
-{ lib, stdenv, fetchFromGitHub, bison, flex, libtool, ncurses, readline, zlib }:
-
-stdenv.mkDerivation rec {
- pname = "foma";
- version = "2022-02-26";
-
- src = fetchFromGitHub {
- owner = "mhulden";
- repo = pname;
- rev = "82f9acdef234eae8b7619ccc3a386cc0d7df62bc";
- hash = "sha256-2ZL7SdjFmf1zD+jRsg0XybyX7mRsqbWV1ZMhiQINwO0=";
- };
-
- sourceRoot = "${src.name}/foma";
-
- nativeBuildInputs = [ bison flex libtool ];
-
- buildInputs = [ ncurses readline zlib ];
-
- postPatch = ''
- substituteInPlace Makefile \
- --replace "CC = gcc" "#CC = gcc" \
- --replace "-ltermcap" "-lncurses"
- '';
-
- makeFlags = [ "prefix=$(out)" ];
-
- meta = with lib; {
- description = "xfst-compatible C++ finite-state transducer library";
- longDescription = ''
- Foma is designed to be a complete replacement for the
- closed-source Xerox tool xfst. Everything that compiles
- with xfst should compile with Foma. If not it is a bug.
- '';
- homepage = "https://code.google.com/p/foma/";
- license = licenses.asl20;
- maintainers = [ maintainers.sikmir ];
- platforms = platforms.unix;
- };
-}