commit 86be4fc1e3fbcbf0e8bced70c916561a692927af
parent dcb4ea46085ca6e106b2c7b3e94ce1321b251107
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sun, 2 Jan 2022 22:08:25 +0300
Add t-rex
Diffstat:
2 files changed, 30 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -184,6 +184,9 @@ lib.makeScope newScope (
rio-mbtiles = callPackage ./geospatial/rio-mbtiles { };
sasplanet-bin = callPackage ./geospatial/sasplanet/bin.nix { };
supermercado = callPackage ./geospatial/supermercado { };
+ t-rex = callPackage ./geospatial/t-rex {
+ inherit (darwin.apple_sdk.frameworks) Security;
+ };
tdh = callPackage ./geospatial/tdh { };
tile-stitch = callPackage ./geospatial/tile-stitch { };
tilesets-cli = callPackage ./geospatial/tilesets-cli { };
diff --git a/pkgs/geospatial/t-rex/default.nix b/pkgs/geospatial/t-rex/default.nix
@@ -0,0 +1,27 @@
+{ lib, rustPlatform, fetchFromGitHub, pkg-config, gdal, openssl, Security }:
+
+rustPlatform.buildRustPackage rec {
+ pname = "t-rex";
+ version = "0.14.2";
+
+ src = fetchFromGitHub {
+ owner = "t-rex-tileserver";
+ repo = pname;
+ rev = "v${version}";
+ hash = "sha256-QNowkQzEYLOgJ2h0yq+gShmW5WgqPF3iiSejqwrOrHo=";
+ };
+
+ cargoHash = "sha256-k10DjLJCJLqjmtEED5pwQDt3mOiey89UYC36lG+3AmM=";
+
+ nativeBuildInputs = [ pkg-config ];
+
+ buildInputs = [ gdal openssl ] ++ lib.optional stdenv.isDarwin Security;
+
+ meta = with lib; {
+ description = "t-rex vector tile server";
+ homepage = "https://t-rex.tileserver.ch/";
+ license = licenses.mit;
+ maintainers = [ maintainers.sikmir ];
+ platforms = platforms.unix;
+ };
+}