commit 84107f4359e6de312496a11c84e74cdfb8152e80
parent 6771b57e64a8e332391c5a34ab38359da7e0502d
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sun, 19 Feb 2023 01:49:33 +0300
Add sloth-bin
Diffstat:
2 files changed, 33 insertions(+), 0 deletions(-)
diff --git a/pkgs/darwin/sloth/default.nix b/pkgs/darwin/sloth/default.nix
@@ -0,0 +1,32 @@
+{ lib, stdenv, fetchfromgh, unzip }:
+
+stdenv.mkDerivation (finalAttrs: {
+ pname = "sloth-bin";
+ version = "3.2";
+
+ src = fetchfromgh {
+ owner = "sveinbjornt";
+ repo = "Sloth";
+ name = "sloth-${finalAttrs.version}.zip";
+ hash = "sha256-8/x8I769V8kGxstDuXXUaMtGvg03n2vhrKvmaltSISo=";
+ inherit (finalAttrs) version;
+ };
+
+ sourceRoot = ".";
+
+ nativeBuildInputs = [ unzip ];
+
+ installPhase = ''
+ mkdir -p $out/Applications
+ cp -r *.app $out/Applications
+ '';
+
+ meta = with lib; {
+ description = "Nice GUI for lsof";
+ homepage = "https://sveinbjorn.org/sloth";
+ license = licenses.bsd3;
+ maintainers = [ maintainers.sikmir ];
+ platforms = [ "x86_64-darwin" ];
+ skip.ci = true;
+ };
+})
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -29,6 +29,7 @@ lib.makeScope newScope (
cudatext-bin = callPackage ./darwin/cudatext/bin.nix { };
macpass-bin = callPackage ./darwin/macpass/bin.nix { };
marta-bin = callPackage ./darwin/marta { };
+ sloth-bin = callPackage ./darwin/sloth { };
### DATA