commit 835e04fcd869a496e11d572afd8a5a8236933835
parent 9ebbd6592cda2684d45ec99265188770dc5f2bb4
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Fri, 16 Sep 2022 01:10:57 +0300
Up
Diffstat:
2 files changed, 9 insertions(+), 14 deletions(-)
diff --git a/pkgs/data/maps/opentopomap/default.nix b/pkgs/data/maps/opentopomap/default.nix
@@ -1,22 +1,17 @@
-{ lib, stdenv, fetchFromGitHub, fetchurl, unzip, mkgmap, mkgmap-splitter }:
+{ lib, stdenv, fetchFromGitHub, fetchurl, unzip, mkgmap, mkgmap-splitter, osm-extracts }:
let
- version = "220808";
- data = fetchurl {
- url = "https://download.geofabrik.de/russia/northwestern-fed-district-${version}.osm.pbf";
- hash = "sha256-YEIsIPrJQYF9HI5lzkU9BOR4D3FxFeTbBMecojunx7A=";
- };
bounds = fetchurl {
- url = "http://osm.thkukuk.de/data/bounds-20220729.zip";
- hash = "sha256-u/8uDVR0RCWn28wez39J4fya5czIG2tTLyAAExiYcFM=";
+ url = "http://osm.thkukuk.de/data/bounds-20220909.zip";
+ hash = "sha256-79zepbGXulWr2QGlFVcIMkzASlTg5DqOEPvx0jcWLYw=";
};
sea = fetchurl {
- url = "http://osm.thkukuk.de/data/sea-20220809001529.zip";
- hash = "sha256-0Nnt7tDZ/qvKfkCfE6Q1CjrqpPRxv1Gd762CK75a0Mo=";
+ url = "http://osm.thkukuk.de/data/sea-20220914001527.zip";
+ hash = "sha256-ntafRbfMMnHy2IlhqKE/DaMinsu9NaXA41HhXb6YVf4=";
};
in
stdenv.mkDerivation rec {
pname = "opentopomap";
- inherit version;
+ inherit (osm-extracts) version;
src = fetchFromGitHub {
owner = "der-stefan";
@@ -36,7 +31,7 @@ stdenv.mkDerivation rec {
'';
buildPhase = ''
- (cd data && splitter --precomp-sea=../sea --output=o5m ${data})
+ (cd data && splitter --precomp-sea=../sea --output=o5m ${osm-extracts.src})
(cd style/typ && mkgmap --family-id=35 opentopomap.txt)
mkgmap \
diff --git a/pkgs/misc/amethyst/bin.nix b/pkgs/misc/amethyst/bin.nix
@@ -2,14 +2,14 @@
stdenv.mkDerivation rec {
pname = "Amethyst-bin";
- version = "0.15.4";
+ version = "0.16.0";
src = fetchfromgh {
owner = "ianyh";
repo = "Amethyst";
version = "v${version}";
name = "Amethyst.zip";
- sha256 = "16n5vdyjs6m4saqibv3fb420w6x83lsiw182qm3prnilh4q9qld3";
+ hash = "sha256-pghX74T0JsAWkxAaAaQ5NIhYqj89fo0ZqRtxPThJZ/M=";
};
sourceRoot = ".";