commit 81a2512de388b92c5d1c1fc2cfd75cf4c81ad65b
parent 32a74db36508722c5ba05832af7311ba9db9a0c4
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Thu, 19 Dec 2019 20:21:39 +0300
Add gpxlab
Diffstat:
3 files changed, 37 insertions(+), 0 deletions(-)
diff --git a/default.nix b/default.nix
@@ -8,6 +8,7 @@ in
{
datamaps = callPackage ./pkgs/datamaps { inherit (sources) datamaps; };
gpx-layer = perlPackages.callPackage ./pkgs/gpx-layer { inherit (sources) gpx-layer; };
+ gpxlab = libsForQt5.callPackage ./pkgs/gpxlab { inherit (sources) GPXLab; };
gpxpy = python3Packages.callPackage ./pkgs/gpxpy { inherit (sources) gpxpy; };
gpxsee-maps = callPackage ./pkgs/gpxsee-maps { inherit (sources) GPXSee-maps; };
gpxtools = callPackage ./pkgs/gpxtools { inherit (sources) gpxtools; };
diff --git a/nix/sources.json b/nix/sources.json
@@ -1,4 +1,16 @@
{
+ "GPXLab": {
+ "branch": "master",
+ "description": "Program to show and manipulate GPS tracks",
+ "homepage": null,
+ "owner": "BourgeoisLab",
+ "repo": "GPXLab",
+ "rev": "68721865f5fd6a5b2414da47a00778d5c342a461",
+ "sha256": "07yrq852cayzrfcwgjzk7h8zp6vnk8639772dsnb4jiqgg8sns42",
+ "type": "tarball",
+ "url": "https://github.com/BourgeoisLab/GPXLab/archive/68721865f5fd6a5b2414da47a00778d5c342a461.tar.gz",
+ "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
+ },
"GPXSee-maps": {
"branch": "master",
"description": "GPXSee maps",
diff --git a/pkgs/gpxlab/default.nix b/pkgs/gpxlab/default.nix
@@ -0,0 +1,24 @@
+{ mkDerivation, lib, qmake, qtbase, qttools, qttranslations, GPXLab }:
+
+mkDerivation rec {
+ pname = "gpxlab";
+ version = lib.substring 0 7 src.rev;
+ src = GPXLab;
+
+ nativeBuildInputs = [ qmake qttools ];
+ buildInputs = [ qtbase qttranslations ];
+
+ preConfigure = ''
+ lrelease GPXLab/locale/*.ts
+ '';
+
+ enableParallelBuilding = true;
+
+ meta = with lib; {
+ homepage = "https://github.com/BourgeoisLab/GPXLab";
+ description = GPXLab.description;
+ license = licenses.gpl3;
+ maintainers = with maintainers; [ sikmir ];
+ platforms = platforms.linux;
+ };
+}