commit 7ffeb7803c25b63df1d1b88a558df9ab4d462ead
parent 77e8ce59c55fbd7735f6cb3649ce09e6aa950175
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Tue, 30 May 2023 22:16:04 +0400
Move flashmq to nixpkgs
Diffstat:
2 files changed, 0 insertions(+), 37 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -380,7 +380,6 @@ lib.makeScope newScope (
### MQTT
emitter = callPackage ./mqtt/emitter { };
- flashmq = callPackage ./mqtt/flashmq { };
go-mqtt-to-influxdb = callPackage ./mqtt/go-mqtt-to-influxdb { };
influxdb-cxx = callPackage ./mqtt/influxdb-cxx { };
janus-mqtt-proxy = callPackage ./mqtt/janus-mqtt-proxy { };
diff --git a/pkgs/mqtt/flashmq/default.nix b/pkgs/mqtt/flashmq/default.nix
@@ -1,36 +0,0 @@
-{ lib, stdenv, fetchFromGitHub, cmake, installShellFiles, openssl }:
-
-stdenv.mkDerivation rec {
- pname = "flashmq";
- version = "1.4.5";
-
- src = fetchFromGitHub {
- owner = "halfgaar";
- repo = "FlashMQ";
- rev = "v${version}";
- hash = "sha256-DcxwwUNpnMeK8A3LuyfrWAMCng0yIcX9bKxNGY0uDSo=";
- };
-
- postPatch = ''
- substituteInPlace mainapp.cpp --replace "/etc/flashmq" "$out/etc/flashmq"
- '';
-
- nativeBuildInputs = [ cmake installShellFiles ];
-
- buildInputs = [ openssl ];
-
- installPhase = ''
- install -Dm755 flashmq -t $out/bin
- install -Dm644 $src/flashmq.conf -t $out/etc/flashmq
- installManPage $src/man/*.{1,5}
- '';
-
- meta = with lib; {
- description = "Fast light-weight MQTT broker/server";
- homepage = "https://www.flashmq.org/";
- license = licenses.agpl3;
- maintainers = [ maintainers.sikmir ];
- platforms = platforms.linux;
- skip.ci = stdenv.isDarwin;
- };
-}