commit 7e9fbd85532dfd7d2b07a76b4d91b140572860f5
parent 7bdd4abdeadc3b49c0cdfeaa902a7b1bdd55f9a1
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sun, 18 Jun 2023 02:27:52 +0400
Add git-tui
Diffstat:
4 files changed, 79 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -337,6 +337,7 @@ lib.makeScope newScope (
finalcut = callPackage ./misc/finalcut { };
freeopcua = callPackage ./misc/freeopcua { };
gaiagpsclient = callPackage ./misc/gaiagpsclient { };
+ git-tui = callPackage ./misc/git-tui { };
glauth = callPackage ./misc/glauth { };
graphene = callPackage ./misc/graphene { };
how-to-use-pvs-studio-free = callPackage ./misc/pvs-studio/how-to-use-pvs-studio-free.nix { };
@@ -369,6 +370,7 @@ lib.makeScope newScope (
sdorfehs = callPackage ./misc/sdorfehs { };
serial-studio-bin = callPackage ./misc/serial-studio/bin.nix { };
serverpp = callPackage ./misc/serverpp { };
+ subprocess = callPackage ./misc/subprocess { };
taskcoach = callPackage ./misc/taskcoach { };
tcvt = callPackage ./misc/tcvt { };
telegabber = callPackage ./misc/telegabber { };
diff --git a/pkgs/misc/git-tui/default.nix b/pkgs/misc/git-tui/default.nix
@@ -0,0 +1,27 @@
+{ lib, stdenv, fetchFromGitHub, cmake, ftxui, subprocess }:
+
+stdenv.mkDerivation rec {
+ pname = "git-tui";
+ version = "1.1.0";
+
+ src = fetchFromGitHub {
+ owner = "ArthurSonzogni";
+ repo = "git-tui";
+ rev = "v${version}";
+ hash = "sha256-RogDZeDgC7HanPd0I+BuU9CShUzaIqvH1R7/I1tAtG4=";
+ };
+
+ patches = [ ./subprocess.patch ];
+
+ nativeBuildInputs = [ cmake ];
+
+ buildInputs = [ ftxui subprocess ];
+
+ meta = with lib; {
+ description = "Collection of human friendly terminal interface for git";
+ inherit (src.meta) homepage;
+ license = licenses.mit;
+ maintainers = [ maintainers.sikmir ];
+ platforms = platforms.unix;
+ };
+}
diff --git a/pkgs/misc/git-tui/subprocess.patch b/pkgs/misc/git-tui/subprocess.patch
@@ -0,0 +1,19 @@
+diff --git i/CMakeLists.txt w/CMakeLists.txt
+index 576057a..4925b07 100644
+--- i/CMakeLists.txt
++++ w/CMakeLists.txt
+@@ -12,10 +12,10 @@ find_or_fetch_package(ftxui v4.0.0
+ d301fab1f4ecdd3544ed99b9c98e647d5804c341
+ )
+
+-find_or_fetch_package(subprocess v0.4.0
+- https://github.com/benman64/subprocess
+- e1cae5e86e5d089e65e906f7c13917b7bbb75d04
+-)
++#find_or_fetch_package(subprocess v0.4.0
++# https://github.com/benman64/subprocess
++# e1cae5e86e5d089e65e906f7c13917b7bbb75d04
++#)
+
+ # ------------------------------------------------------------------------------
+
diff --git a/pkgs/misc/subprocess/default.nix b/pkgs/misc/subprocess/default.nix
@@ -0,0 +1,31 @@
+{ lib, stdenv, fetchFromGitHub, cmake, python3 }:
+
+stdenv.mkDerivation rec {
+ pname = "subprocess";
+ version = "0.4.0";
+
+ src = fetchFromGitHub {
+ owner = "benman64";
+ repo = "subprocess";
+ rev = "v${version}";
+ hash = "sha256-Tgmihv7SJfYpOYHvtuE8rgFzUHyl4bJh9W5CSqotVMg=";
+ };
+
+ nativeBuildInputs = [ cmake ];
+
+ buildInputs = [ python3 ];
+
+ installPhase = ''
+ install -Dm644 $src/src/cpp/*.hpp -t $out/include
+ install -Dm644 $src/src/cpp/subprocess/*.hpp -t $out/include/subprocess
+ install -Dm644 subprocess/libsubprocess.a -t $out/lib
+ '';
+
+ meta = with lib; {
+ description = "Cross platform subprocess library for c++ similar to design of python subprocess";
+ inherit (src.meta) homepage;
+ license = licenses.mit;
+ maintainers = [ maintainers.sikmir ];
+ platforms = platforms.unix;
+ };
+}