commit 7a9b087472aec9181a5f8c645d70a0c2ef8b1317
parent f37977e1cfb66e77b38c874c0d7525eeb34e5c80
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Thu, 23 Jul 2020 22:05:02 +0300
Add gpxlib
Diffstat:
3 files changed, 36 insertions(+), 0 deletions(-)
diff --git a/nix/sources.json b/nix/sources.json
@@ -247,6 +247,20 @@
"url": "https://github.com/BourgeoisLab/GPXLab/archive/c9e2daf790ce7eb88c3bdcf17b98541d60c40894.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
},
+ "gpxlib": {
+ "branch": "master",
+ "builtin": false,
+ "date": "2019-11-27T18:32:49Z",
+ "description": "A c++ library for parsing, browsing, changing and writing of GPX files",
+ "homepage": "http://irdvo.nl/gpxlib/",
+ "owner": "irdvo",
+ "repo": "gpxlib",
+ "rev": "9c247c4892156af13a8c32c14121115c8ff934b2",
+ "sha256": "1g5j0bv4l3jh9wxjizx4im5hyl32jm7xrw03ysaxd29dpvwr07y2",
+ "type": "tarball",
+ "url": "https://github.com/irdvo/gpxlib/archive/9c247c4892156af13a8c32c14121115c8ff934b2.tar.gz",
+ "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
+ },
"gpxsee": {
"branch": "master",
"builtin": false,
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -70,6 +70,7 @@ lib.makeScope newScope (
libtool = if pkgs.stdenv.isDarwin then pkgs.darwin.cctools else null;
};
geographiclib = callPackage ./development/libraries/geographiclib { };
+ gpxlib = callPackage ./development/libraries/gpxlib { };
hfst = callPackage ./development/libraries/hfst { };
libgarmin = callPackage ./development/libraries/libgarmin {
automake = pkgs.automake111x;
diff --git a/pkgs/development/libraries/gpxlib/default.nix b/pkgs/development/libraries/gpxlib/default.nix
@@ -0,0 +1,21 @@
+{ stdenv, cmake, expat, sources }:
+let
+ pname = "gpxlib";
+ date = stdenv.lib.substring 0 10 sources.gpxlib.date;
+ version = "unstable-" + date;
+in
+stdenv.mkDerivation {
+ inherit pname version;
+ src = sources.gpxlib;
+
+ nativeBuildInputs = [ cmake ];
+
+ buildInputs = [ expat ];
+
+ meta = with stdenv.lib; {
+ inherit (sources.gpxlib) description homepage;
+ license = licenses.lgpl3;
+ maintainers = with maintainers; [ sikmir ];
+ platforms = platforms.unix;
+ };
+}