commit 76e3f3d178fdf78a2e0633f11c556e5cca913c30
parent 8b97645da0e60725d9e6c9c0477a708ca0240aec
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Wed, 12 Feb 2025 12:37:24 +0400
Up
Diffstat:
7 files changed, 28 insertions(+), 19 deletions(-)
diff --git a/flake.lock b/flake.lock
@@ -20,11 +20,11 @@
},
"nixpkgs": {
"locked": {
- "lastModified": 1738958807,
- "narHash": "sha256-h0WKgHTLkjwjRNTkqByQquS7N/15SqIFMQ356Ww8uCA=",
+ "lastModified": 1739138025,
+ "narHash": "sha256-M4ilIfGxzbBZuURokv24aqJTbdjPA9K+DtKUzrJaES4=",
"owner": "nixos",
"repo": "nixpkgs",
- "rev": "e8d0b02af0958823c955aaab3c82b03f54411d91",
+ "rev": "b2243f41e860ac85c0b446eadc6930359b294e79",
"type": "github"
},
"original": {
diff --git a/pkgs/darwin/zed/default.nix b/pkgs/darwin/zed/default.nix
@@ -7,11 +7,11 @@
stdenvNoCC.mkDerivation (finalAttrs: {
pname = "zed";
- version = "0.173.4-pre";
+ version = "0.173.5-pre";
src = fetchurl {
url = "https://zed.dev/api/releases/stable/${finalAttrs.version}/Zed-x86_64.dmg";
- hash = "sha256-KZ3vYXt9rB2NRogOUdMSqM1/wOfknDCGZ5qzYMfmkvY=";
+ hash = "sha256-QHtnUnTmIASB4Voet5dpbOwP6wSdWlVG5Rt5UD6ahWA=";
};
sourceRoot = ".";
diff --git a/pkgs/data/maps/slazav/hr.nix b/pkgs/data/maps/slazav/hr.nix
@@ -12,6 +12,7 @@
mapsoft2,
netpbm,
sqlite,
+ unstableGitUpdater,
zip,
}:
@@ -57,6 +58,8 @@ stdenv.mkDerivation {
install -Dm644 OUT/* -t $out
'';
+ passthru.updateScript = unstableGitUpdater { };
+
meta = {
description = "Slazav mountains";
homepage = "https://slazav.xyz/maps/hr.htm";
diff --git a/pkgs/data/maps/slazav/podm.nix b/pkgs/data/maps/slazav/podm.nix
@@ -12,6 +12,7 @@
mapsoft2,
netpbm,
sqlite,
+ unstableGitUpdater,
zip,
}:
@@ -52,6 +53,8 @@ stdenv.mkDerivation {
install -Dm644 OUT/* -t $out
'';
+ passthru.updateScript = unstableGitUpdater { };
+
meta = {
description = "Slazav Moscow region map";
homepage = "https://slazav.xyz/maps/podm.htm";
diff --git a/pkgs/geospatial/go-staticmaps/default.nix b/pkgs/geospatial/go-staticmaps/default.nix
@@ -2,22 +2,25 @@
lib,
buildGoModule,
fetchFromGitHub,
+ unstableGitUpdater,
}:
buildGoModule {
pname = "go-staticmaps";
- version = "0-unstable-2021-12-31";
+ version = "0-unstable-2025-02-06";
src = fetchFromGitHub {
owner = "flopp";
repo = "go-staticmaps";
- rev = "56e3560e444bd7855f8de837dd491cb0a4bd5ae9";
- hash = "sha256-r1PQ45hLy/akquN1vhuhCu+71E8ptjT1boCXupbH8lw=";
+ rev = "47d062eaabcee02a9008db85b959e089314bde94";
+ hash = "sha256-jnM2GrN4HyVGarnopH0DCmI+Gfh4DLHWZNqiJu0GrwA=";
};
patches = [ ./extra-tileproviders.patch ];
- vendorHash = "sha256-VwdQsm7VghVtX2O41jNxILTuiLff4rTfXP41+IzUmMs=";
+ vendorHash = "sha256-NrkwyKcVZ1IJv70CIOXD+GCvFhuKoEPYSi9V4sHrkcs=";
+
+ passthru.updateScript = unstableGitUpdater { };
meta = {
description = "A go (golang) library and command line tool to render static map images using OpenStreetMap tiles";
diff --git a/pkgs/geospatial/go-staticmaps/extra-tileproviders.patch b/pkgs/geospatial/go-staticmaps/extra-tileproviders.patch
@@ -1,8 +1,8 @@
-diff --git i/tile_provider.go w/tile_provider.go
-index be2c487..7adac9c 100644
---- i/tile_provider.go
-+++ w/tile_provider.go
-@@ -143,6 +143,28 @@ func NewTileProviderArcgisWorldImagery() *TileProvider {
+diff --git c/tile_provider.go i/tile_provider.go
+index 727363e..da297b4 100644
+--- c/tile_provider.go
++++ i/tile_provider.go
+@@ -163,6 +163,28 @@ func NewTileProviderNone() *TileProvider {
return t
}
@@ -29,12 +29,12 @@ index be2c487..7adac9c 100644
+}
+
// GetTileProviders returns a map of all available TileProviders
- func GetTileProviders() map[string]*TileProvider {
+ func GetTileProviders(thunderforestApiKey string) map[string]*TileProvider {
m := make(map[string]*TileProvider)
-@@ -162,6 +184,8 @@ func GetTileProviders() map[string]*TileProvider {
- NewTileProviderCartoDark(),
+@@ -181,6 +203,8 @@ func GetTileProviders(thunderforestApiKey string) map[string]*TileProvider {
NewTileProviderArcgisWorldImagery(),
NewTileProviderWikimedia(),
+ NewTileProviderNone(),
+ NewTileProviderOpenTopoMapRu(),
+ NewTileProviderInkatlas(),
}
diff --git a/pkgs/geospatial/py-staticmaps/default.nix b/pkgs/geospatial/py-staticmaps/default.nix
@@ -7,13 +7,13 @@
python3Packages.buildPythonApplication rec {
pname = "py-staticmaps";
- version = "0.3.0";
+ version = "0.5.0";
src = fetchFromGitHub {
owner = "flopp";
repo = "py-staticmaps";
tag = "v${version}";
- hash = "sha256-vW457HbdDDhfz8hsvEN3/HJmIHKdrRDVNuhSpZXoZ78=";
+ hash = "sha256-TWLPCM1tsWiRCLDhowC/uQrDUujNO3FuDgnUQXMcTm0=";
};
dependencies = with python3Packages; [