commit 7639ce78efad17fc518e41e1fec2c2496bd35ff0
parent 76d8efa79c2996a52aef5cc9a008a5cef78b20fc
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Fri, 20 May 2022 09:42:30 +0300
Move tilemaker to nixpkgs
Diffstat:
2 files changed, 0 insertions(+), 38 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -350,7 +350,6 @@ lib.makeScope newScope (
inherit (darwin.apple_sdk.frameworks) Foundation;
};
taginfo-tools = callPackage ./osm/taginfo-tools { };
- tilemaker = callPackage ./osm/tilemaker { };
vectiler = callPackage ./osm/vectiler { };
### RADIO
diff --git a/pkgs/osm/tilemaker/default.nix b/pkgs/osm/tilemaker/default.nix
@@ -1,37 +0,0 @@
-{ lib, stdenv, fetchFromGitHub, cmake, installShellFiles
-, boost, lua, protobuf, rapidjson, shapelib, sqlite, zlib }:
-
-stdenv.mkDerivation rec {
- pname = "tilemaker";
- version = "2.2.0";
-
- src = fetchFromGitHub {
- owner = "systemed";
- repo = pname;
- rev = "v${version}";
- hash = "sha256-st6WDCk1RZ2lbfrudtcD+zenntyTMRHrIXw3nX5FHOU=";
- };
-
- postPatch = ''
- substituteInPlace src/tilemaker.cpp \
- --replace "config.json" "$out/share/tilemaker/config-openmaptiles.json" \
- --replace "process.lua" "$out/share/tilemaker/process-openmaptiles.lua"
- '';
-
- nativeBuildInputs = [ cmake installShellFiles ];
-
- buildInputs = [ boost lua protobuf rapidjson shapelib sqlite zlib ];
-
- postInstall = ''
- installManPage $src/docs/man/tilemaker.1
- install -Dm644 $src/resources/* -t $out/share/tilemaker
- '';
-
- meta = with lib; {
- description = "Make OpenStreetMap vector tiles without the stack";
- inherit (src.meta) homepage;
- license = licenses.free;
- maintainers = [ maintainers.sikmir ];
- platforms = platforms.unix;
- };
-}