commit 7380f6b60d77b558d6811d9268e48313dca04c88
parent 35ed8ec31f7435dfe2d2694ee4934a6099f7adf0
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sun, 7 Jul 2024 20:01:25 +0400
Up
Diffstat:
2 files changed, 15 insertions(+), 21 deletions(-)
diff --git a/pkgs/osm/level0/default.nix b/pkgs/osm/level0/default.nix
@@ -1,35 +1,25 @@
{
lib,
- stdenvNoCC,
fetchFromGitHub,
+ php,
conf ? null,
}:
-stdenvNoCC.mkDerivation rec {
+php.buildComposerProject (finalAttrs: {
pname = "level0";
- version = "2021-06-08";
+ version = "2024-06-24";
src = fetchFromGitHub {
owner = "Zverik";
repo = "Level0";
- rev = "fa92855bce868bc7f5f8d3c1510985d97db1e3b8";
- hash = "sha256-IendoFItO8w9z1HdDh9Z6vLvPrDRFRtYsLhOrIqDezM=";
+ rev = "390c8108c3cd7c7599129542ea48ed6f792213d1";
+ hash = "sha256-4gp3E4FdHAZX+PCi+v+f0cTVhB2MqkkIcGAQrXQqLZg=";
};
- postPatch = ''
- substituteInPlace locales/deploy_locales \
- --replace-fail "../www" "$out/www" \
- --replace-fail "source " "#source "
- '';
+ vendorHash = "sha256-+49ednqEuhTNO6t20SdkSYYSL9v8QNehxVWLgCuJWW0=";
configFile = lib.optionalString (conf != null) (builtins.toFile "config.php" conf);
- preBuild = lib.optionalString (conf != null) "cp ${configFile} www/config.php";
-
- installPhase = ''
- mkdir -p $out
- cp -r www $out/www
- (cd locales; ./deploy_locales)
- '';
+ preBuild = lib.optionalString (conf != null) "cp ${finalAttrs.configFile} www/config.php";
meta = {
description = "Web-based OpenStreetMap Editor";
@@ -37,4 +27,4 @@ stdenvNoCC.mkDerivation rec {
license = lib.licenses.wtfpl;
maintainers = [ lib.maintainers.sikmir ];
};
-}
+})
diff --git a/pkgs/suckless/imscript/default.nix b/pkgs/suckless/imscript/default.nix
@@ -3,6 +3,8 @@
stdenv,
fetchFromSourcehut,
installShellFiles,
+ hdf5,
+ libheif,
libpng,
libjpeg,
libtiff,
@@ -14,18 +16,20 @@
stdenv.mkDerivation (finalAttrs: {
pname = "imscript";
- version = "0-unstable-2024-05-21";
+ version = "0-unstable-2024-07-05";
src = fetchFromSourcehut {
owner = "~coco";
repo = "imscript";
- rev = "4471616ad570350c8b046d683c613178d949284e";
- hash = "sha256-Dbtzaru63BXdi+1m0iKM0QGaunJB/52clgQOxVaJg60=";
+ rev = "b146c88ed05988e025ec10ff1e75471c57cd2542";
+ hash = "sha256-43jcjQJT/x3duP+uEUrhA/nTX+VHEDOoxtOPOqd78tQ=";
};
nativeBuildInputs = [ installShellFiles ];
buildInputs = [
+ hdf5
+ libheif
libpng
libjpeg
libtiff