commit 72e7810bd6fa52b0fdb5022f99efeb36160f3712
parent 48be6be9e818af4b1a16107a3526689977194aa6
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sat, 28 Oct 2023 17:21:43 +0400
Add mqcontrol
Diffstat:
2 files changed, 23 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -407,6 +407,7 @@ lib.makeScope newScope (
janus-mqtt-proxy = callPackage ./mqtt/janus-mqtt-proxy { };
mongoose = callPackage ./mqtt/mongoose { };
mproxy = callPackage ./mqtt/mproxy { };
+ mqcontrol = callPackage ./mqtt/mqcontrol { };
mqtt-benchmark = callPackage ./mqtt/mqtt-benchmark { };
mqtt-cli = callPackage ./mqtt/mqtt-cli { };
mqtt-explorer = callPackage ./mqtt/mqtt-explorer { };
diff --git a/pkgs/mqtt/mqcontrol/default.nix b/pkgs/mqtt/mqcontrol/default.nix
@@ -0,0 +1,22 @@
+{ stdenv, lib, fetchFromGitHub, buildGoModule }:
+
+buildGoModule rec {
+ pname = "mqcontrol";
+ version = "0.5.0";
+
+ src = fetchFromGitHub {
+ owner = "albertnis";
+ repo = "mqcontrol";
+ rev = "v${version}";
+ hash = "sha256-rsmWrKOEJjd74ElsaR7Rk7FsY0wwSgG/AzYB5LcmWNQ=";
+ };
+
+ vendorHash = "sha256-tuSrIq2DHMy2KY2z3ZMAwC28UGHrZifAWmOFx5Y4pKU=";
+
+ meta = with lib; {
+ description = "Cross-platform utility to execute commands remotely using MQTT";
+ inherit (src.meta) homepage;
+ license = licenses.free;
+ maintainers = [ maintainers.sikmir ];
+ };
+}