commit 6f78fab025f7de8456ad447b6f09de766b1c8ba8
parent 98f3781935f19c596d5f3fc033060e02fc7cf6b2
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Thu, 17 Jun 2021 13:39:36 +0300
Add gpx-animator
Diffstat:
2 files changed, 36 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -194,6 +194,10 @@ lib.makeScope newScope (
sasplanet-bin = callPackage ./gis/sasplanet/bin.nix { };
tdh = callPackage ./gis/tdh { };
+ ### GPX
+
+ gpx-animator = callPackage ./gpx/gpx-animator { };
+
### IMAGES
dockerImages = {
diff --git a/pkgs/gpx/gpx-animator/default.nix b/pkgs/gpx/gpx-animator/default.nix
@@ -0,0 +1,32 @@
+{ lib, stdenv, fetchurl, jre, makeWrapper }:
+
+stdenv.mkDerivation rec {
+ pname = "gpx-animator";
+ version = "1.6.1";
+
+ src = fetchurl {
+ url = "https://download.gpx-animator.app/gpx-animator-${version}-all.jar";
+ hash = "sha256-f99lz8EtAZnQB2BE773oiISHrqGfgsG/mCvFnd1Xrtc=";
+ };
+
+ nativeBuildInputs = [ makeWrapper ];
+
+ dontUnpack = true;
+
+ installPhase = ''
+ install -dm755 $out/bin
+ install -Dm644 $src $out/share/java/${src.name}
+
+ makeWrapper ${jre}/bin/java $out/bin/gpx-animator \
+ --add-flags "-jar $out/share/java/gpx-animator-${version}-all.jar"
+ '';
+
+ meta = with lib; {
+ description = "GPX Animator";
+ homepage = "https://gpx-animator.app/";
+ license = licenses.asl20;
+ maintainers = [ maintainers.sikmir ];
+ platforms = platforms.unix;
+ skip.ci = true;
+ };
+}