commit 6e5fdc597497c909fdf00e4352639b3ed97fe790
parent 2265774f3f2c1d74c466952d1da05c0b2aced9e2
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Tue, 10 Oct 2023 17:53:19 +0400
Fix platforms
Diffstat:
5 files changed, 9 insertions(+), 9 deletions(-)
diff --git a/pkgs/applications/synwrite/bin.nix b/pkgs/applications/synwrite/bin.nix
@@ -39,7 +39,7 @@ stdenv.mkDerivation rec {
homepage = "http://uvviewsoft.com/synwrite/";
license = licenses.mpl11;
maintainers = [ maintainers.sikmir ];
- platforms = platforms.all;
+ platforms = wine.meta.platforms;
skip.ci = true;
};
}
diff --git a/pkgs/geospatial/hecate/default.nix b/pkgs/geospatial/hecate/default.nix
@@ -2,16 +2,16 @@
rustPlatform.buildRustPackage rec {
pname = "hecate";
- version = "0.82.2";
+ version = "0.87.0";
src = fetchFromGitHub {
- owner = "Mapbox";
+ owner = "Hecate";
repo = "Hecate";
rev = "v${version}";
- hash = "sha256-ffDBcrrg7iC8XkA1HO+qiRzZfNS6bF4mEXXqdM8w3uA=";
+ hash = "sha256-X+49Mnls5xK6ag1QcvEm0GvLPmvcRBwNn/1vnC9GJO8=";
};
- cargoHash = "sha256-OwKQiDRgYVSIIDnmjWyXSvFc3/L/dgcOjuXf/lE4N68=";
+ cargoHash = "sha256-ROx90hWk9q5E/Yfy9luHbB1XyyLqw2KEl92niBNapBI=";
nativeBuildInputs = [ pkg-config ];
diff --git a/pkgs/geospatial/sasplanet/bin.nix b/pkgs/geospatial/sasplanet/bin.nix
@@ -56,7 +56,7 @@ stdenv.mkDerivation (finalAttrs: {
changelog = "http://www.sasgis.org/mantis/changelog_page.php";
license = licenses.gpl3Plus;
maintainers = [ maintainers.sikmir ];
- platforms = platforms.all;
+ platforms = wine.meta.platforms;
skip.ci = true;
};
})
diff --git a/pkgs/geospatial/tdh/default.nix b/pkgs/geospatial/tdh/default.nix
@@ -1,7 +1,7 @@
-{ callPackage, fetchFromGitHub, wxGTK, gcc8Stdenv }:
+{ callPackage, fetchFromGitHub, wxGTK30, gcc8Stdenv }:
let
# Fix mismatch between the program and library build versions
- wxGTK30_gcc8 = (wxGTK.override { stdenv = gcc8Stdenv; compat26 = false; }).overrideAttrs (old: {
+ wxGTK30_gcc8 = (wxGTK30.override { stdenv = gcc8Stdenv; compat26 = false; }).overrideAttrs (old: {
version = "3.0.5";
src = fetchFromGitHub {
owner = "wxWidgets";
diff --git a/pkgs/gpx/gpxeditor/default.nix b/pkgs/gpx/gpxeditor/default.nix
@@ -31,7 +31,7 @@ stdenv.mkDerivation (finalAttrs: {
homepage = "https://sourceforge.net/projects/gpxeditor/";
license = licenses.gpl2;
maintainers = [ maintainers.sikmir ];
- platforms = platforms.all;
+ platforms = wine.meta.platforms;
skip.ci = true;
};
})