commit 6e10a8858eb83dd661c4e6dada8c3097cc835ab8
parent a230faf422416c8871e38574a290bc8ca09b3e78
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sun, 12 Mar 2023 22:02:16 +0400
Add wik
Diffstat:
2 files changed, 26 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -354,6 +354,7 @@ lib.makeScope newScope (
telnetpp = callPackage ./misc/telnetpp { };
tinyflux = callPackage ./misc/tinyflux { };
tlstunnel = callPackage ./misc/tlstunnel { };
+ wik = callPackage ./misc/wik { };
worm = callPackage ./misc/worm { };
wptools = callPackage ./misc/wptools { };
xfractint = callPackage ./misc/xfractint { };
diff --git a/pkgs/misc/wik/default.nix b/pkgs/misc/wik/default.nix
@@ -0,0 +1,25 @@
+{ lib, stdenv, fetchFromGitHub, python3Packages }:
+
+python3Packages.buildPythonApplication rec {
+ pname = "wik";
+ version = "2023-03-12";
+ format = "flit";
+
+ src = fetchFromGitHub {
+ owner = "yashsinghcodes";
+ repo = "wik";
+ rev = "7dd7b9ebd4070e4b3a1475948dac67b8288ce17a";
+ hash = "sha256-aJnBY33JB4xsH8AIcQGVli8OuIqbTulB26t7uj2GzVk=";
+ };
+
+ nativeBuildInputs = with python3Packages; [ flit-core ];
+
+ propagatedBuildInputs = with python3Packages; [ beautifulsoup4 requests ];
+
+ meta = with lib; {
+ description = "wik is use to get information about anything on the shell using Wikipedia";
+ inherit (src.meta) homepage;
+ license = licenses.mit;
+ maintainers = [ maintainers.sikmir ];
+ };
+}