commit 6e0c4f44791cdafe9e6fbceea7a62dbb93e2b544
parent 49dd3dda7f20e3f3d27b214c9edfd2a4d96442cc
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Thu, 9 Jun 2022 12:36:23 +0300
Remove opendict
Diffstat:
3 files changed, 0 insertions(+), 54 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -268,7 +268,6 @@ lib.makeScope newScope (
lsdreader = callPackage ./linguistics/lsdreader { };
mikatools = callPackage ./linguistics/mikatools { };
odict = callPackage ./linguistics/odict { };
- opendict = callPackage ./linguistics/opendict { };
python-hfst = callPackage ./linguistics/python-hfst { };
pytorchtext = callPackage ./linguistics/pytorchtext { };
redict = libsForQt5.callPackage ./linguistics/redict { };
diff --git a/pkgs/linguistics/opendict/0001-fix-makefile.patch b/pkgs/linguistics/opendict/0001-fix-makefile.patch
@@ -1,20 +0,0 @@
-diff --git i/Makefile w/Makefile
-index 80654d8..bf634c3 100644
---- i/Makefile
-+++ w/Makefile
-@@ -30,12 +30,11 @@ install:
-
- $(MAKE) -C po install prefix=$(DESTDIR)
-
-- cp opendict.py $(opendictdir)
-- chmod a+rx $(opendictdir)/opendict.py
-+ mkdir -p $(bindir)
-+ cp opendict.py $(bindir)/opendict
-+ chmod a+rx $(bindir)/opendict
- cp copying.html $(opendictdir)
- chmod a+r $(opendictdir)/copying.html
-- mkdir -p $(bindir)
-- ln -sf $(opendictdir)/opendict.py $(bindir)/opendict
- mkdir -p $(DESTDIR)/share/applications
- cp misc/opendict.desktop $(DESTDIR)/share/applications
- chmod a+r $(DESTDIR)/share/applications/opendict.desktop
diff --git a/pkgs/linguistics/opendict/default.nix b/pkgs/linguistics/opendict/default.nix
@@ -1,33 +0,0 @@
-{ lib, fetchFromGitHub, python2Packages, gettext }:
-
-python2Packages.buildPythonApplication rec {
- pname = "opendict";
- version = "0.6.8";
-
- src = fetchFromGitHub {
- owner = "nerijus";
- repo = pname;
- rev = version;
- hash = "sha256-blHHAYTCRrN84oPvt44cFJRBpBCdqewRkGs1tbOr6kk=";
- };
-
- patches = [ ./0001-fix-makefile.patch ];
-
- nativeBuildInputs = [ gettext ];
- propagatedBuildInputs = with python2Packages; [ wxPython30 ];
-
- dontUseSetuptoolsBuild = true;
- dontUseSetuptoolsCheck = true;
- dontUsePipInstall = true;
-
- makeFlags = [ "DESTDIR=$(out)" ];
- makeWrapperArgs = [ "--prefix PYTHONPATH : $out/share/opendict" ];
-
- meta = with lib; {
- description = "Free multiplatform dictionary";
- homepage = "http://opendict.sf.net/";
- license = licenses.gpl2Plus;
- maintainers = [ maintainers.sikmir ];
- skip.ci = true;
- };
-}