commit 6d8c98471aad29b3dc6e4a7ef52083f6f7e6302e
parent 99624e91d3f63ce009a49bf1852da3346d33f38d
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sun, 24 Mar 2024 21:33:46 +0400
Add ais-catcher
Diffstat:
2 files changed, 51 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -509,6 +509,7 @@ lib.makeScope newScope (
### RADIO
acarsdec = callPackage ./radio/acarsdec { };
+ ais-catcher = callPackage ./radio/ais-catcher { };
aprsc = callPackage ./radio/aprsc { };
dumphfdl = callPackage ./radio/dumphfdl { };
dumpvdl2 = callPackage ./radio/dumpvdl2 {
diff --git a/pkgs/radio/ais-catcher/default.nix b/pkgs/radio/ais-catcher/default.nix
@@ -0,0 +1,50 @@
+{ lib
+, stdenv
+, fetchFromGitHub
+, cmake
+, pkg-config
+, airspy
+, airspyhf
+, hackrf
+, libsamplerate
+, openssl
+, rtl-sdr
+, soxr
+, zeromq
+, zlib
+}:
+
+stdenv.mkDerivation (finalAttrs: {
+ pname = "ais-catcher";
+ version = "0.58";
+
+ src = fetchFromGitHub {
+ owner = "jvde-github";
+ repo = "AIS-catcher";
+ rev = "v${finalAttrs.version}";
+ hash = "sha256-7kN3EVyjlktnU7mhQa3emD8zqf9OSlzoh4xW8LLpvL8=";
+ };
+
+ nativeBuildInputs = [ cmake pkg-config ];
+
+ buildInputs = [
+ airspy
+ airspyhf
+ hackrf
+ libsamplerate
+ openssl
+ rtl-sdr
+ soxr
+ zeromq
+ zlib
+ ];
+
+ meta = with lib; {
+ description = "A multi-platform AIS Receiver";
+ inherit (finalAttrs.src.meta) homepage;
+ license = licenses.gpl3Plus;
+ maintainers = [ maintainers.sikmir ];
+ platforms = platforms.unix;
+ mainProgram = "AIS-catcher";
+ };
+})