commit 6c375dbbe9958e4473d8077859326f49148b2822
parent 4b43b7699e68b73335a2e30f2301b9f72d42331a
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Thu, 18 Mar 2021 20:21:24 +0300
Add cmpgpx
Diffstat:
2 files changed, 35 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -116,6 +116,9 @@ lib.makeScope newScope (
### TOOLS
+ cmpgpx = callPackage ./tools/geo/cmpgpx {
+ inherit geotiler;
+ };
datamaps = callPackage ./tools/geo/datamaps { };
elevation = callPackage ./tools/geo/elevation {
click = click-6-7;
diff --git a/pkgs/tools/geo/cmpgpx/default.nix b/pkgs/tools/geo/cmpgpx/default.nix
@@ -0,0 +1,32 @@
+{ lib, fetchFromGitHub, python3Packages, geotiler }:
+
+python3Packages.buildPythonApplication {
+ pname = "cmpgpx";
+ version = "2015-06-05";
+
+ src = fetchFromGitHub {
+ owner = "jonblack";
+ repo = "cmpgpx";
+ rev = "ec3ff781da9b7bcbc2dee44a3bd641cbd5005efe";
+ sha256 = "1fq215a8xa2q3nppab162dabs4nxyh0x2sd631k40gn3n14s75l8";
+ };
+
+ propagatedBuildInputs = with python3Packages; [ cairocffi geotiler gpxpy numpy ];
+
+ dontUseSetuptoolsBuild = true;
+ dontUseSetuptoolsCheck = true;
+
+ installPhase = ''
+ install -Dm644 geo.py gfx.py -t $out/lib/${python3Packages.python.libPrefix}/site-packages
+ install -Dm755 cmpgpx.py $out/bin/cmpgpx
+ install -Dm755 dist.py $out/bin/dist
+ '';
+
+ meta = with lib; {
+ description = "Show the differences between GPX files";
+ homepage = "https://github.com/jonblack/cmpgpx";
+ license = licenses.unlicense;
+ maintainers = [ maintainers.sikmir ];
+ platforms = platforms.unix;
+ };
+}