commit 6af1229723200b6e3270772c5f7375e53cbd4f38
parent af4eadbd678ebe4f590fe824b87fe308b61f5028
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sun, 9 Jun 2024 10:50:18 +0400
Move python-periphery to nixpkgs
Diffstat:
2 files changed, 0 insertions(+), 28 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -115,7 +115,6 @@ lib.makeScope newScope (
pytest-mp = callPackage ./development/python-modules/pytest-mp { };
pytest-shell-utilities = callPackage ./development/python-modules/pytest-shell-utilities { };
pytest-skip-markers = callPackage ./development/python-modules/pytest-skip-markers { };
- python-periphery = callPackage ./development/python-modules/python-periphery { };
s2sphere = callPackage ./development/python-modules/s2sphere { };
### EMBEDDED
diff --git a/pkgs/development/python-modules/python-periphery/default.nix b/pkgs/development/python-modules/python-periphery/default.nix
@@ -1,27 +0,0 @@
-{
- lib,
- stdenv,
- fetchFromGitHub,
- python3Packages,
-}:
-
-python3Packages.buildPythonPackage rec {
- pname = "python-periphery";
- version = "2.4.1";
-
- src = fetchFromGitHub {
- owner = "vsergeev";
- repo = "python-periphery";
- rev = "v${version}";
- hash = "sha256-vRK1jeLG+z+yOYGGACO6dYSpzfO9NhNiThVTt35maaU=";
- };
-
- meta = {
- description = "A pure Python 2/3 library for peripheral I/O (GPIO, LED, PWM, SPI, I2C, MMIO, Serial) in Linux";
- inherit (src.meta) homepage;
- license = lib.licenses.mit;
- maintainers = [ lib.maintainers.sikmir ];
- platforms = lib.platforms.linux;
- skip.ci = stdenv.isDarwin;
- };
-}