commit 68784b8079e36dc38d84e0bd1ad3269b25dee15e
parent 8d5f26cebab28148f723ac83763f614884153845
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sun, 4 Dec 2022 00:01:52 +0300
mapsoft2: 1.8 → 2.0
Diffstat:
2 files changed, 20 insertions(+), 13 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -187,9 +187,7 @@ lib.makeScope newScope (
inherit (darwin.apple_sdk.frameworks) Security;
};
localtileserver = callPackage ./geospatial/localtileserver { };
- mapsoft = callPackage ./geospatial/mapsoft {
- proj = pkgs.proj_7;
- };
+ mapsoft = callPackage ./geospatial/mapsoft { };
mapsoft2 = callPackage ./geospatial/mapsoft/2.nix { };
mbtiles2osmand = callPackage ./geospatial/mbtiles2osmand { };
mbutiles = callPackage ./geospatial/mbutiles { };
diff --git a/pkgs/geospatial/mapsoft/2.nix b/pkgs/geospatial/mapsoft/2.nix
@@ -3,9 +3,11 @@
, fetchFromGitHub
, substituteAll
, db
+, fig2dev
, giflib
, gsettings-desktop-schemas
, gtkmm3
+, imagemagick
, jansson
, curl
, libjpeg
@@ -24,13 +26,13 @@
stdenv.mkDerivation (finalAttrs: {
pname = "mapsoft2";
- version = "1.8";
+ version = "2.0";
src = fetchFromGitHub {
owner = "slazav";
repo = "mapsoft2";
rev = "${finalAttrs.version}-alt1";
- hash = "sha256-RWY+rFVwPTZOyAZt1Bytcer4KiriGGfgke5s+qAydx8=";
+ hash = "sha256-cZHxCqfAY0DT3Zr3AdY3BMtzsiC9yXA2CUD/uM27SRE=";
fetchSubmodules = true;
};
@@ -47,17 +49,16 @@ stdenv.mkDerivation (finalAttrs: {
--replace "/usr/share" "$out/share"
patchShebangs .
- # https://github.com/OSGeo/PROJ/pull/2547
- cat > modules/pc/proj.pc << EOF
- Name: PROJ
- Description: Coordinate transformation software library
- Requires:
- Version: ${proj.version}
- Libs: -lproj
- EOF
+ substituteInPlace vmap_data/scripts/vmaps_preview --replace "vmaps.sh" "$out/bin/vmaps.sh"
+ substituteInPlace vmap_data/scripts/vmaps_out --replace "vmaps.sh" "$out/bin/vmaps.sh"
+ substituteInPlace vmap_data/scripts/vmaps_get_fig --replace "vmaps.sh" "$out/bin/vmaps.sh"
+ substituteInPlace vmap_data/scripts/vmaps_in --replace "vmaps.sh" "$out/bin/vmaps.sh"
+ substituteInPlace vmap_data/scripts/vmaps.sh --replace "/usr" "$out"
'';
nativeBuildInputs = [
+ fig2dev
+ imagemagick
perlPackages.perl
pkg-config
unzip
@@ -84,6 +85,14 @@ stdenv.mkDerivation (finalAttrs: {
makeFlags = [ "prefix=$(out)" ];
+ dontWrapGApps = true;
+
+ postFixup = ''
+ for f in $out/bin/ms2*; do
+ wrapGApp $f
+ done
+ '';
+
meta = with lib; {
description = "A collection of tools and libraries for working with maps and geo-data";
homepage = "http://slazav.github.io/mapsoft2";