commit 6782cb838eb83ec10dc4b12255c4da1c55165c2e
parent efb847ca8dcb62496df577495c729b73b35d1d3b
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sun, 13 Aug 2023 23:54:38 +0400
osmcoastline: fix build
Diffstat:
1 file changed, 10 insertions(+), 2 deletions(-)
diff --git a/pkgs/osm/osmcoastline/default.nix b/pkgs/osm/osmcoastline/default.nix
@@ -1,6 +1,7 @@
{ lib
, stdenv
, fetchFromGitHub
+, fetchpatch
, cmake
, bzip2
, expat
@@ -14,15 +15,22 @@
stdenv.mkDerivation (finalAttrs: {
pname = "osmcoastline";
- version = "2.3.1";
+ version = "2.4.0";
src = fetchFromGitHub {
owner = "osmcode";
repo = "osmcoastline";
rev = "v${finalAttrs.version}";
- hash = "sha256-z72xDag3CDik/zGhQjlmE/Yfz/KEwK/A1clyP3AY7Uo=";
+ hash = "sha256-HSUBUSKO0gfUTECjzFpaAu9ye5Qho3rRqhYpc9du+ig=";
};
+ patches = [
+ (fetchpatch {
+ url = "https://github.com/osmcode/osmcoastline/commit/67cc33161069f65e315acae952492ab5ee07af15.patch";
+ hash = "sha256-6x2WrVm0vI2H8W3jTTdCSlAGNYbc6dfujlr3cHWhC3Y=";
+ })
+ ];
+
nativeBuildInputs = [ cmake ];
buildInputs = [