commit 656a9330c9437f02c8244b1c5a901600af28eb53
parent 1788acffa97caf9c913120d358b82a8972674d9a
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Mon, 27 Nov 2023 15:32:22 +0400
Up
Diffstat:
4 files changed, 15 insertions(+), 17 deletions(-)
diff --git a/flake.lock b/flake.lock
@@ -20,11 +20,11 @@
},
"nixpkgs": {
"locked": {
- "lastModified": 1700856099,
- "narHash": "sha256-RnEA7iJ36Ay9jI0WwP+/y4zjEhmeN6Cjs9VOFBH7eVQ=",
+ "lastModified": 1701040486,
+ "narHash": "sha256-vawYwoHA5CwvjfqaT3A5CT9V36Eq43gxdwpux32Qkjw=",
"owner": "nixos",
"repo": "nixpkgs",
- "rev": "0bd59c54ef06bc34eca01e37d689f5e46b3fe2f1",
+ "rev": "45827faa2132b8eade424f6bdd48d8828754341a",
"type": "github"
},
"original": {
diff --git a/pkgs/darwin/qtcreator/bin.nix b/pkgs/darwin/qtcreator/bin.nix
@@ -8,7 +8,7 @@ stdenv.mkDerivation (finalAttrs: {
owner = "qt-creator";
repo = "qt-creator";
name = "qtcreator-macos-universal-${finalAttrs.version}.7z";
- hash = "sha256-ZuBJs4dX48RHEsHSGeyHITVWlCo7wRcT6VG7d9wzSa8=";
+ hash = "sha256-G5NX3o/C4I0S/6kQ9MlpVLx+rLDWueQe7egbiVntloY=";
version = "v${finalAttrs.version}";
};
diff --git a/pkgs/geospatial/mobroute/default.nix b/pkgs/geospatial/mobroute/default.nix
@@ -2,23 +2,22 @@
buildGoModule rec {
pname = "mobroute";
- version = "2023-10-05";
+ version = "0.2.0";
src = fetchFromSourcehut {
owner = "~mil";
repo = "mobroute";
- rev = "2b86d414bfb7d56f623436b957b6da2de9fa1659";
- hash = "sha256-4hzmict+jHwkmw/SMsTytX8zooUPSdeNBpdRq5dVWNs=";
+ rev = "v${version}";
+ hash = "sha256-mYoJnBE8d2UH8vwIrMFcI49q6o+ZLnkWs9QDkDDtRLk=";
};
- vendorHash = "sha256-KPh3Iuy6pujzRvGBLKXipcXa9sy1/MNTrFvFeXiIMcY=";
+ vendorHash = "sha256-ZIGchgsN1d6MqiY/SE5zS990A1Yyo8RwdbaQkRBXdC0=";
- postPatch = ''
+ checkFlags = [
# --- FAIL: Test_ExecuteCSA (0.00s)
# csa_test.go:104: CSAExecute error: Couldn't determine cheapest arrival destination, consider increasing max_walk_seconds or max_transfer_seconds
- substituteInPlace src/csa_test/csa_test.go \
- --replace "Test_ExecuteCSA" "Skip_ExecuteCSA"
- '';
+ "-skip=Test_ExecuteCSA"
+ ];
postInstall = ''
mv $out/bin/{src,mobroute}
diff --git a/pkgs/mqtt/emitter/default.nix b/pkgs/mqtt/emitter/default.nix
@@ -11,11 +11,6 @@ buildGoModule rec {
hash = "sha256-oLTAWw6JgW8yF+pvAhQtaATvOpA/8tKN+pGZQXYYv6c=";
};
- postPatch = ''
- substituteInPlace internal/provider/monitor/statsd_test.go \
- --replace "TestStatsd_Configure" "SkipStatsd_Configure"
- '';
-
vendorHash = "sha256-5BeYdznpopkz4XhdKu5MXZ5qhpHntAe+h17XsKLrGd0=";
preCheck = ''
@@ -24,6 +19,10 @@ buildGoModule rec {
doCheck = false;
+ checkFlags = [
+ "-skip=TestStatsd_Configure"
+ ];
+
meta = with lib; {
description = "High performance, distributed and low latency publish-subscribe platform";
homepage = "https://emitter.io/";