commit 6562462f64bf86e643e6d16c260329041d96a03e
parent 3d6e0abb80792c555e5e14a71157a34aa7962fbb
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Sat, 31 Jul 2021 12:38:31 +0300
Up
Diffstat:
4 files changed, 18 insertions(+), 15 deletions(-)
diff --git a/pkgs/data/maps/maptourist/default.nix b/pkgs/data/maps/maptourist/default.nix
@@ -2,11 +2,11 @@
stdenvNoCC.mkDerivation rec {
pname = "maptourist";
- version = "2021-07-24";
+ version = "2021-07-30";
src = fetchurl {
url = "https://maptourist.org/osm-garmin/archive/OSM-MapTourist-szfo-RU_${version}.zip";
- hash = "sha256-UFQLDYMYiwazKrSavOJepNdD/jB5ySCchEYT/7Exl4E=";
+ hash = "sha256-3H3+ulLzP+yEMIulpRZLQq27IxBbp7Mn7BsG/9zzPHg=";
};
sourceRoot = ".";
diff --git a/pkgs/gemini/gurl/default.nix b/pkgs/gemini/gurl/default.nix
@@ -1,22 +1,24 @@
{ lib, stdenv, fetchFromGitHub, zig }:
stdenv.mkDerivation rec {
- pname = "gurl-unstable";
- version = "2020-12-28";
+ pname = "gurl";
+ version = "2021-03-06";
src = fetchFromGitHub {
owner = "MasterQ32";
- repo = "gurl";
- rev = "13e2999a8c86a84ed9b3054f1f7ef9613387b778";
- sha256 = "0yyxgl9kj25frz1m2wwvbrpl83r7w1pkqp52zfm2qhrv6qzjqic7";
+ repo = pname;
+ rev = "c6491a0760c125ca50d86860f77b544f729d8885";
+ sha256 = "sha256-l7WasR1rdD6DV3JWDIGcUlVkypnIKLNoKaVbibdibQc=";
fetchSubmodules = true;
};
nativeBuildInputs = [ zig ];
- buildPhase = "HOME=$TMP zig build install";
+ preConfigure = "HOME=$TMP";
- installPhase = "install -Dm755 zig-cache/bin/gurl -t $out/bin";
+ buildPhase = "zig build";
+
+ installPhase = "install -Dm755 zig-out/bin/gurl -t $out/bin";
meta = with lib; {
description = "A curl-like cli application to interact with Gemini sites";
@@ -24,6 +26,5 @@ stdenv.mkDerivation rec {
license = licenses.mit;
maintainers = [ maintainers.sikmir ];
platforms = platforms.unix;
- broken = true; # https://github.com/MasterQ32/gurl/issues/4
};
}
diff --git a/pkgs/misc/aamath/default.nix b/pkgs/misc/aamath/default.nix
@@ -1,4 +1,4 @@
-{ lib, stdenv, fetchwebarchive, fetchpatch, readline, ncurses, bison, flex }:
+{ lib, stdenv, fetchwebarchive, fetchpatch, readline, ncurses, bison, flex, installShellFiles }:
stdenv.mkDerivation rec {
pname = "aamath";
@@ -23,13 +23,13 @@ stdenv.mkDerivation rec {
--replace "-ltermcap" "-lncurses"
'';
- nativeBuildInputs = [ bison flex ];
+ nativeBuildInputs = [ bison flex installShellFiles ];
buildInputs = [ readline ncurses ];
installPhase = ''
install -Dm755 aamath -t $out/bin
- install -Dm644 aamath.1 -t $out/share/man/man1
+ installManPage aamath.1
'';
meta = with lib; {
diff --git a/pkgs/osm/phyghtmap/default.nix b/pkgs/osm/phyghtmap/default.nix
@@ -1,4 +1,4 @@
-{ lib, python3Packages, fetchurl }:
+{ lib, python3Packages, fetchurl, installShellFiles }:
python3Packages.buildPythonApplication rec {
pname = "phyghtmap";
@@ -9,9 +9,11 @@ python3Packages.buildPythonApplication rec {
hash = "sha256-jA6uc/HVdrDQF3NX0Cbu4wMl4SSd7cA/VOvtRRzDsBM=";
};
+ nativeBuildInputs = [ installShellFiles ];
+
propagatedBuildInputs = with python3Packages; [ beautifulsoup4 lxml matplotlib numpy ];
- postInstall = "install -Dm644 docs/phyghtmap.1 -t $out/share/man/man1";
+ postInstall = "installManPage docs/phyghtmap.1";
meta = with lib; {
description = "Generate OSM contour lines from NASA SRTM data";