commit 64fc4af65fcc10879d2c831be5f1f63d6a21f676
parent cccd5950215979562369936b57420a8fde72f907
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Fri, 10 Jul 2020 19:23:16 +0300
Add glauth
Diffstat:
3 files changed, 41 insertions(+), 0 deletions(-)
diff --git a/nix/sources.json b/nix/sources.json
@@ -166,6 +166,19 @@
"url": "https://github.com/wuyongzheng/gimgtools/archive/92d015749e105c5fb8eb704ae503a5c7e51af2bd.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
},
+ "glauth": {
+ "branch": "master",
+ "builtin": false,
+ "description": "A lightweight LDAP server for development, home use, or CI",
+ "homepage": "https://github.com/glauth/glauth",
+ "owner": "glauth",
+ "repo": "glauth",
+ "rev": "a92f9a7028fdf68952ffbed4958167b928dbc483",
+ "sha256": "1aa01jz1aal4zrbjx6a5d8mspnbqq8nsjvshknc5dad0myc4nkyr",
+ "type": "tarball",
+ "url": "https://github.com/glauth/glauth/archive/a92f9a7028fdf68952ffbed4958167b928dbc483.tar.gz",
+ "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
+ },
"gpx-layer": {
"branch": "master",
"builtin": false,
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -169,6 +169,7 @@ lib.makeScope newScope (
### SERVERS
+ glauth = callPackage ./servers/glauth { };
mbtileserver = callPackage ./servers/mbtileserver { };
nakarte = callPackage ./servers/nakarte { };
pg_tileserv = callPackage ./servers/pg_tileserv { };
diff --git a/pkgs/servers/glauth/default.nix b/pkgs/servers/glauth/default.nix
@@ -0,0 +1,27 @@
+{ lib, buildGoModule, go-bindata, sources }:
+
+buildGoModule {
+ pname = "glauth";
+ version = lib.substring 0 7 sources.glauth.rev;
+ src = sources.glauth;
+
+ vendorSha256 = "18inm0s9mww7c19z9alnvy0g80d3laxh4lwbgzkcc8kf9zg25149";
+
+ nativeBuildInputs = [ go-bindata ];
+
+ buildFlagsArray = ''
+ -ldflags=
+ -X main.GitCommit=${sources.glauth.rev}
+ '';
+
+ preBuild = ''
+ go-bindata -pkg=assets -o=pkg/assets/bindata.go assets
+ '';
+
+ meta = with lib; {
+ inherit (sources.glauth) description homepage;
+ license = licenses.mit;
+ maintainers = with maintainers; [ sikmir ];
+ platforms = platforms.unix;
+ };
+}