commit 63e5cdf499e3a3531d5e9668f65ba236756e9964
parent 971c2d2b54d5a6e0b3195f7b2a2da49204ac7651
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Thu, 25 Aug 2022 16:04:13 +0300
Up
Diffstat:
4 files changed, 18 insertions(+), 13 deletions(-)
diff --git a/flake.lock b/flake.lock
@@ -17,11 +17,11 @@
},
"nixpkgs": {
"locked": {
- "lastModified": 1660639432,
- "narHash": "sha256-2WDiboOCfB0LhvnDVMXOAr8ZLDfm3WdO54CkoDPwN1A=",
+ "lastModified": 1661336769,
+ "narHash": "sha256-5Sf9tMd1Jdm+lTBGspbQ4kEoYCDKpUhEVAZHRcm6mGU=",
"owner": "NixOS",
"repo": "nixpkgs",
- "rev": "6c6409e965a6c883677be7b9d87a95fab6c3472e",
+ "rev": "03428dbaaa23d6bf458770907b0927b377c873a8",
"type": "github"
},
"original": {
diff --git a/pkgs/misc/pnoise/default.nix b/pkgs/misc/pnoise/default.nix
@@ -11,8 +11,6 @@ python3Packages.buildPythonApplication rec {
hash = "sha256-JwWzLvgCNSLRs/ToZNFH6fN6VLEsQTmsgxxkugwjA9k=";
};
- postPatch = "sed -i 's/>=.*\"/\"/' setup.py";
-
propagatedBuildInputs = with python3Packages; [ numpy ];
checkInputs = with python3Packages; [ pytestCheckHook ];
diff --git a/pkgs/misc/tlstunnel/default.nix b/pkgs/misc/tlstunnel/default.nix
@@ -1,14 +1,14 @@
{ lib, fetchFromGitHub, ocamlPackages }:
-ocamlPackages.buildDunePackage rec {
+ocamlPackages.buildDunePackage {
pname = "tlstunnel";
- version = "2021-08-06";
+ version = "2022-01-09";
src = fetchFromGitHub {
owner = "roburio";
- repo = pname;
- rev = "3aef371d7f91f09c8e6ab56d94c227a26c3060d9";
- hash = "sha256-7ik3uHinHojidFvlxeJdsVGwvZ8yfqDfoEcMokUVJEg=";
+ repo = "tlstunnel";
+ rev = "4f70374a22ea6e7913e420f85246308186eed9c8";
+ hash = "sha256-pY3z95jU5WPqaAIdGab9JcYgKxcPLAmjlZlPZ23F2Bk=";
};
useDune2 = true;
@@ -16,10 +16,10 @@ ocamlPackages.buildDunePackage rec {
propagatedBuildInputs = with ocamlPackages; [
asn1-combinators
cmdliner
+ fmt
ipaddr
logs
mirage-crypto
- rresult
];
meta = with lib; {
diff --git a/pkgs/radio/fmreceiver/default.nix b/pkgs/radio/fmreceiver/default.nix
@@ -1,4 +1,4 @@
-{ lib, stdenv, fetchFromGitHub, fftwFloat, libsamplerate, libsndfile, libusb1
+{ lib, stdenv, fetchFromGitHub, fetchpatch, fftwFloat, libsamplerate, libsndfile, libusb1
, portaudio, rtl-sdr, qmake, qwt, wrapQtAppsHook
}:
@@ -13,6 +13,14 @@ stdenv.mkDerivation rec {
hash = "sha256-U0m9PIB+X+TBoz5FfXMvR/tZjkNIy7B613I7eLT5UIs=";
};
+ patches = [
+ # support qwt-6.2.0
+ (fetchpatch {
+ url = "https://github.com/JvanKatwijk/sdr-j-fm/commit/4ca2f3a28e3e3460dc95be851fcd923e91488573.patch";
+ hash = "sha256-tjNsg9Rc8kBn+6UzPsf1WLt+ZRYv8neG/CSyZKjObh0=";
+ })
+ ];
+
postPatch = ''
substituteInPlace fmreceiver.pro \
--replace "-lqwt-qt5" "-lqwt" \
@@ -47,6 +55,5 @@ stdenv.mkDerivation rec {
license = licenses.gpl2Plus;
maintainers = [ maintainers.sikmir ];
platforms = platforms.unix;
- broken = true;
};
}