commit 5ec8612c513b6c6e2f51928aa0c63cab635711a7
parent 3a8d8949a7bf8bd5b0aa1282a5983b352f04a713
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Sat, 21 Nov 2020 17:37:06 +0300
Add elevation_server
Diffstat:
3 files changed, 104 insertions(+), 0 deletions(-)
diff --git a/nix/sources.json b/nix/sources.json
@@ -111,6 +111,20 @@
"url": "https://github.com/bopen/elevation/archive/1930e479d0fceee86351f33226ab0cac411492e2.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
},
+ "elevation-server": {
+ "branch": "master",
+ "builtin": false,
+ "date": "2020-06-22T13:35:45Z",
+ "description": "The server providing elevation data for https://nakarte.me written in go",
+ "homepage": "https://github.com/wladich/elevation_server",
+ "owner": "wladich",
+ "repo": "elevation_server",
+ "rev": "f8f944b4fb7190782aa57b5eeb467bdff8b349bd",
+ "sha256": "0619jxchha0iy8x7g5k5pfyw7x62iwjd19m29b69w53y3dsiswbc",
+ "type": "tarball",
+ "url": "https://github.com/wladich/elevation_server/archive/f8f944b4fb7190782aa57b5eeb467bdff8b349bd.tar.gz",
+ "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
+ },
"embox": {
"branch": "master",
"builtin": false,
diff --git a/pkgs/servers/elevation_server/default.nix b/pkgs/servers/elevation_server/default.nix
@@ -0,0 +1,25 @@
+{ lib, buildGoPackage, lz4, sources }:
+let
+ pname = "elevation-server";
+ date = lib.substring 0 10 sources.elevation-server.date;
+ version = "unstable-" + date;
+in
+buildGoPackage rec {
+ inherit pname version;
+ src = sources.elevation-server;
+
+ goPackagePath = "github.com/wladich/elevation_server";
+
+ subPackages = [ "cmd/elevation_server" "cmd/make_data" ];
+
+ buildInputs = [ lz4 ];
+
+ goDeps = ./deps.nix;
+
+ meta = with lib; {
+ inherit (sources.elevation-server) description homepage;
+ license = licenses.free;
+ maintainers = [ maintainers.sikmir ];
+ platforms = platforms.unix;
+ };
+}
diff --git a/pkgs/servers/elevation_server/deps.nix b/pkgs/servers/elevation_server/deps.nix
@@ -0,0 +1,65 @@
+[
+ {
+ goPackagePath = "github.com/cheggaaa/pb";
+ fetch = {
+ type = "git";
+ url = "https://github.com/cheggaaa/pb";
+ rev = "f53c49a21d379f442c3b8f3f6e6adf7a0a01e438";
+ sha256 = "111n0pn1mc3qfdkvl4by82zxxr8n6v8pshh5nd2kg9ij5ayrc61k";
+ };
+ }
+ {
+ goPackagePath = "github.com/mattn/go-runewidth";
+ fetch = {
+ type = "git";
+ url = "https://github.com/mattn/go-runewidth";
+ rev = "14e809f6d78fcf9f48ff9b70981472b64c05f754";
+ sha256 = "1mvlxcdwr0vwp8b2wqs6y7hk72y28sqh03dz5x0xkg48d4y9cplj";
+ };
+ }
+ {
+ goPackagePath = "golang.org/x/sys";
+ fetch = {
+ type = "git";
+ url = "https://go.googlesource.com/sys";
+ rev = "f84b799fce68db3cb46a8f6f819c1e56377181df";
+ sha256 = "1dvhqian5byzkcg1bnqzygqa6ccc6krc2q7j12pp1vhl3y7znnsg";
+ };
+ }
+ {
+ goPackagePath = "github.com/VividCortex/ewma";
+ fetch = {
+ type = "git";
+ url = "https://github.com/VividCortex/ewma";
+ rev = "41f1bc0f7cb2f39d665ca5735fb093191d9252d0";
+ sha256 = "17gl3dcnbba3srasbwr2jmwjg6rh1msm1zi3cjichpi9fdvrdj40";
+ };
+ }
+ {
+ goPackagePath = "github.com/fatih/color";
+ fetch = {
+ type = "git";
+ url = "https://github.com/fatih/color";
+ rev = "bc2269661d49c6c9d0e514eef49710556883f3fa";
+ sha256 = "1azg1r8ifnr1pk5lvqkpcssqb7s7hs0zym1fmg0k67p842bvm2n8";
+ };
+ }
+ {
+ goPackagePath = "github.com/mattn/go-colorable";
+ fetch = {
+ type = "git";
+ url = "https://github.com/mattn/go-colorable";
+ rev = "f6c00982823144337e56cdb71c712eaac151d29c";
+ sha256 = "08y5c01bvyqxraj3wc0di80gbp87178rsshb74x0p3m7wwfv82l3";
+ };
+ }
+ {
+ goPackagePath = "github.com/mattn/go-isatty";
+ fetch = {
+ type = "git";
+ url = "https://github.com/mattn/go-isatty";
+ rev = "cb30d6282491c185f77d9bec5d25de1bb61a06bc";
+ sha256 = "0v59mv94acd2m72q8adhigxkx1vn38l5h0d8hp0nxga2v9f3v8kd";
+ };
+ }
+]