commit 5d9c6e4aa33ae11c84b0ada3fdefe9ab09906ffa
parent 4879725669acdd9c15936697b916c65fd47080b4
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Tue, 26 May 2020 20:11:40 +0300
Fix platforms
Diffstat:
4 files changed, 9 insertions(+), 19 deletions(-)
diff --git a/pkgs/applications/wireguard-statusbar/default.nix b/pkgs/applications/wireguard-statusbar/default.nix
@@ -23,7 +23,7 @@ stdenv.mkDerivation rec {
homepage = "https://github.com/aequitas/macos-menubar-wireguard";
license = licenses.gpl3;
maintainers = with maintainers; [ sikmir ];
- platforms = with platforms; darwin;
+ platforms = [ "x86_64-darwin" ];
skip.ci = true;
};
}
diff --git a/pkgs/tools/geo/cgpsmapper/default.nix b/pkgs/tools/geo/cgpsmapper/default.nix
@@ -10,22 +10,18 @@ stdenv.mkDerivation rec {
};
sourceRoot = ".";
- unpackCmd = ''
- gunzip -c $curSrc > cgpsmapper-static
- '';
+ unpackCmd = "gunzip -c $curSrc > ${pname}-static";
dontBuild = true;
dontFixup = true;
- installPhase = ''
- install -Dm755 cgpsmapper-static -t "$out/bin"
- '';
+ installPhase = "install -Dm755 ${pname}-static -t $out/bin";
meta = with stdenv.lib; {
description = "GIS converter into GARMIN compatible format maps";
homepage = "https://web.archive.org/web/20160620061746if_/http://www.cgpsmapper.com";
license = licenses.free;
maintainers = with maintainers; [ sikmir ];
- platforms = platforms.linux;
+ platforms = [ "i686-linux" "x86_64-linux" ];
};
}
diff --git a/pkgs/tools/geo/gmaptool/default.nix b/pkgs/tools/geo/gmaptool/default.nix
@@ -13,15 +13,13 @@ stdenv.mkDerivation rec {
dontBuild = true;
dontFixup = true;
- installPhase = ''
- install -Dm755 gmt -t "$out/bin"
- '';
+ installPhase = "install -Dm755 gmt -t $out/bin";
meta = with stdenv.lib; {
description = "Program for splitting and merging maps in Garmin format";
homepage = "https://www.gmaptool.eu";
license = licenses.cc-by-sa-30;
maintainers = with maintainers; [ sikmir ];
- platforms = platforms.linux;
+ platforms = [ "i686-linux" "x86_64-linux" ];
};
}
diff --git a/pkgs/tools/geo/sendmap20/default.nix b/pkgs/tools/geo/sendmap20/default.nix
@@ -10,22 +10,18 @@ stdenv.mkDerivation rec {
};
sourceRoot = ".";
- unpackCmd = ''
- gunzip -c $curSrc > sendmap20
- '';
+ unpackCmd = "gunzip -c $curSrc > sendmap20";
dontBuild = true;
dontFixup = true;
- installPhase = ''
- install -Dm755 sendmap20 -t "$out/bin"
- '';
+ installPhase = "install -Dm755 sendmap20 -t $out/bin";
meta = with stdenv.lib; {
description = "Software for uploading maps to your GPS";
homepage = "https://web.archive.org/web/20160620061746if_/http://www.cgpsmapper.com";
license = licenses.free;
maintainers = with maintainers; [ sikmir ];
- platforms = platforms.linux;
+ platforms = [ "i686-linux" "x86_64-linux" ];
};
}