commit 5d759f9800bdd52a833aae288f5ae81c62bacaea
parent adb7dea5ba68362a9739c18d1bef146b613835e4
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Wed, 19 Feb 2020 11:17:06 +0300
Fix CI build
Diffstat:
3 files changed, 3 insertions(+), 1 deletion(-)
diff --git a/ci.nix b/ci.nix
@@ -17,7 +17,7 @@ let
isReserved = n: n == "lib" || n == "overlays" || n == "modules";
isDerivation = p: isAttrs p && p ? type && p.type == "derivation";
- isBuildable = p: !(p.meta.broken or false) && p.meta.license.free or true;
+ isBuildable = p: !(p.meta.broken or false) && !(p.meta.skip.ci or false) && p.meta.license.free or true;
isCacheable = p: !(p.preferLocalBuild or false);
shouldRecurseForDerivations = p: isAttrs p && p.recurseForDerivations or false;
diff --git a/pkgs/data/maps/slazav/hr.nix b/pkgs/data/maps/slazav/hr.nix
@@ -42,5 +42,6 @@ stdenv.mkDerivation rec {
license = licenses.free;
maintainers = with maintainers; [ sikmir ];
platforms = platforms.all;
+ skip.ci = true;
};
}
diff --git a/pkgs/data/maps/slazav/podm.nix b/pkgs/data/maps/slazav/podm.nix
@@ -40,5 +40,6 @@ stdenv.mkDerivation rec {
license = licenses.free;
maintainers = with maintainers; [ sikmir ];
platforms = platforms.all;
+ skip.ci = true;
};
}