commit 5ccd20460c86c5cd35134d5ee04ce72ef731cf24
parent 2b50538cbe9f3a319d04c2d08e5fe4327a0e3773
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sat, 6 Apr 2024 14:04:18 +0400
Move sloth to nixpkgs
Diffstat:
2 files changed, 0 insertions(+), 38 deletions(-)
diff --git a/pkgs/darwin/sloth/default.nix b/pkgs/darwin/sloth/default.nix
@@ -1,37 +0,0 @@
-{ lib, stdenvNoCC, fetchfromgh, unzip, makeWrapper }:
-
-stdenvNoCC.mkDerivation (finalAttrs: {
- pname = "sloth";
- version = "3.2";
-
- src = fetchfromgh {
- owner = "sveinbjornt";
- repo = "Sloth";
- name = "sloth-${finalAttrs.version}.zip";
- hash = "sha256-8/x8I769V8kGxstDuXXUaMtGvg03n2vhrKvmaltSISo=";
- inherit (finalAttrs) version;
- };
-
- sourceRoot = ".";
-
- nativeBuildInputs = [ unzip makeWrapper ];
-
- installPhase = ''
- runHook preInstall
- mkdir -p $out/Applications
- mv *.app $out/Applications
- makeWrapper $out/{Applications/Sloth.app/Contents/MacOS/Sloth,bin/sloth}
- runHook postInstall
- '';
-
- meta = with lib; {
- description = "Nice GUI for lsof";
- homepage = "https://sveinbjorn.org/sloth";
- sourceProvenance = with sourceTypes; [ binaryNativeCode ];
- license = licenses.bsd3;
- maintainers = [ maintainers.sikmir ];
- platforms = [ "x86_64-darwin" ];
- mainProgram = "sloth";
- skip.ci = true;
- };
-})
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -41,7 +41,6 @@ lib.makeScope newScope (
qtcreator-bin = callPackage ./darwin/qtcreator/bin.nix { };
qutebrowser-bin = callPackage ./darwin/qutebrowser/bin.nix { };
sequel-ace = callPackage ./darwin/sequel-ace { };
- sloth = callPackage ./darwin/sloth { };
zed = callPackage ./darwin/zed { };
### DATA