commit 5a0ede28ab579b146064e29d872e78f8c092b1c4
parent b10508d63634d33c4f2c56d5f2174ff5f85f6c3a
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Tue, 20 Oct 2020 21:01:34 +0300
Move keeweb to nixpkgs
Diffstat:
2 files changed, 0 insertions(+), 72 deletions(-)
diff --git a/pkgs/applications/keeweb/bin.nix b/pkgs/applications/keeweb/bin.nix
@@ -1,71 +0,0 @@
-{ stdenv, fetchfromgh, appimageTools, undmg, libsecret }:
-let
- inherit (stdenv.hostPlatform) system;
- throwSystem = throw "Unsupported system: ${system}";
-
- pname = "keeweb";
- version = "1.15.7";
- name = "${pname}-${version}";
-
- suffix = {
- x86_64-linux = "linux.AppImage";
- x86_64-darwin = "mac.dmg";
- }.${system} or throwSystem;
-
- src = fetchfromgh {
- owner = "keeweb";
- repo = "keeweb";
- version = "v${version}";
- name = "KeeWeb-${version}.${suffix}";
- sha256 = {
- x86_64-linux = "0cy0avl0m07xs523xm0rzsmifl28sv4rjb2jj3x492qmr2v64ckk";
- x86_64-darwin = "0r8c3zi0ibj0bb0gfc1axfn0y4qpjqfr0xpcxf810d65kaz6wic4";
- }.${system} or throwSystem;
- };
-
- appimageContents = appimageTools.extract {
- inherit name src;
- };
-
- meta = with stdenv.lib; {
- description = "Free cross-platform password manager compatible with KeePass";
- homepage = "https://keeweb.info/";
- license = licenses.mit;
- maintainers = [ maintainers.sikmir ];
- platforms = [ "x86_64-linux" "x86_64-darwin" ];
- skip.ci = true;
- };
-
- linux = appimageTools.wrapType2 rec {
- inherit name src meta;
-
- extraPkgs = pkgs: with pkgs; [ libsecret ];
-
- extraInstallCommands = ''
- mv $out/bin/{${name},${pname}}
- install -Dm644 ${appimageContents}/keeweb.desktop -t $out/share/applications
- install -Dm644 ${appimageContents}/keeweb.png -t $out/share/icons/hicolor/256x256/apps
- install -Dm644 ${appimageContents}/usr/share/mime/keeweb.xml -t $out/share/mime
- substituteInPlace $out/share/applications/keeweb.desktop \
- --replace 'Exec=AppRun' 'Exec=${pname}'
- '';
- };
-
- darwin = stdenv.mkDerivation {
- inherit name src meta;
-
- preferLocalBuild = true;
-
- nativeBuildInputs = [ undmg ];
-
- sourceRoot = "KeeWeb.app";
-
- installPhase = ''
- mkdir -p $out/Applications/KeeWeb.app
- cp -R . $out/Applications/KeeWeb.app
- '';
- };
-in
-if stdenv.isDarwin
-then darwin
-else linux
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -20,7 +20,6 @@ lib.makeScope newScope (
};
gpxsee-bin = callPackage ./applications/gpxsee/bin.nix { };
iterm2-bin = callPackage ./applications/iterm2/bin.nix { };
- keeweb-bin = callPackage ./applications/keeweb/bin.nix { };
librewolf = callPackage ./applications/librewolf { };
macpass-bin = callPackage ./applications/macpass/bin.nix { };
mapsoft = callPackage ./applications/mapsoft { };