commit 553fb755a2b234acc0b4a12db8b3692c69eee723
parent 1bac6d6e37451a4469f25592738391f0cde90e2d
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Mon, 15 May 2023 01:44:50 +0400
Up
Diffstat:
3 files changed, 5 insertions(+), 2 deletions(-)
diff --git a/pkgs/development/python-modules/contextily/default.nix b/pkgs/development/python-modules/contextily/default.nix
@@ -2,14 +2,14 @@
python3Packages.buildPythonPackage rec {
pname = "contextily";
- version = "1.2.0";
+ version = "1.3.0";
disabled = python3Packages.pythonOlder "3.6";
src = fetchFromGitHub {
owner = "geopandas";
repo = "contextily";
rev = "v${version}";
- hash = "sha256-ByLPd75MZCsa8l24lkIZVNX4RrT8LN3D0O4tLOb6hTI=";
+ hash = "sha256-s8F70I9xrNvYqS8t2kWX7cgjfGqGYLfiAZAYvaKVS6s=";
};
propagatedBuildInputs = with python3Packages; [
@@ -30,5 +30,6 @@ python3Packages.buildPythonPackage rec {
homepage = "https://github.com/geopandas/contextily";
license = licenses.bsd3;
maintainers = [ maintainers.sikmir ];
+ broken = stdenv.isDarwin; # xyzservices
};
}
diff --git a/pkgs/osm/phyghtmap/default.nix b/pkgs/osm/phyghtmap/default.nix
@@ -24,5 +24,6 @@ python3Packages.buildPythonApplication rec {
homepage = "http://katze.tfiu.de/projects/phyghtmap";
license = licenses.gpl2Plus;
maintainers = [ maintainers.sikmir ];
+ broken = stdenv.isDarwin; # xyzservices
};
}
diff --git a/pkgs/osm/polytiles/default.nix b/pkgs/osm/polytiles/default.nix
@@ -23,5 +23,6 @@ python3Packages.buildPythonApplication rec {
inherit (src.meta) homepage;
license = licenses.wtfpl;
maintainers = [ maintainers.sikmir ];
+ broken = true; # python-mapnik
};
}