commit 5340bc83e4edda25b69e5e735e90c807030854e2
parent 0913dd21e693157f9f1c3fac06234138f134a374
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Fri, 24 Jul 2020 11:20:02 +0300
Add gpxsee-bin
Diffstat:
2 files changed, 31 insertions(+), 0 deletions(-)
diff --git a/pkgs/applications/gpxsee/bin.nix b/pkgs/applications/gpxsee/bin.nix
@@ -0,0 +1,30 @@
+{ stdenv, fetchurl, undmg, sources }:
+let
+ pname = "gpxsee";
+ version = "7.31";
+in
+stdenv.mkDerivation {
+ inherit pname version;
+
+ src = fetchurl {
+ url = "mirror://sourceforge/gpxsee/GPXSee-${version}.dmg";
+ sha256 = "0gjpk89q5c1y9anmm26jv18i54dadn7q7r1djfsmsx77ibsbk8dm";
+ };
+
+ preferLocalBuild = true;
+
+ nativeBuildInputs = [ undmg ];
+
+ installPhase = ''
+ mkdir -p $out/Applications/GPXSee.app
+ cp -R . $out/Applications/GPXSee.app
+ '';
+
+ meta = with stdenv.lib; {
+ inherit (sources.gpxsee) description homepage;
+ license = licenses.gpl3;
+ maintainers = [ maintainers.sikmir ];
+ platforms = [ "x86_64-darwin" ];
+ skip.ci = true;
+ };
+}
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -14,6 +14,7 @@ lib.makeScope newScope (
gpxsee = libsForQt5.callPackage ./applications/gpxsee {
inherit sources;
};
+ gpxsee-bin = callPackage ./applications/gpxsee/bin.nix { };
keeweb-bin = callPackage ./applications/keeweb/bin.nix { };
librewolf = callPackage ./applications/librewolf { };
macpass-bin = callPackage ./applications/macpass/bin.nix { };