commit 52301168d3df056d9c8511abfe3709133267f79d
parent 6181ac6a92f82f12a93790fa56388b59c20f24e8
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Tue, 29 Mar 2022 22:53:55 +0300
wikitextprocessor: fix build
Diffstat:
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/pkgs/linguistics/wikitextprocessor/default.nix b/pkgs/linguistics/wikitextprocessor/default.nix
@@ -1,6 +1,6 @@
{ lib, stdenv, python3Packages, fetchFromGitHub, lru-dict }:
-python3Packages.buildPythonApplication rec {
+python3Packages.buildPythonPackage rec {
pname = "wikitextprocessor";
version = "0.4.95";
@@ -15,7 +15,9 @@ python3Packages.buildPythonApplication rec {
checkInputs = with python3Packages; [ pytestCheckHook ];
- disabledTests = lib.optionals stdenv.isDarwin [
+ disabledTests = [
+ "test_string_format2"
+ ] ++ lib.optionals stdenv.isDarwin [
"test_long_twothread"
"test_expr29"
];