commit 4c6632da6fd0abee41522c61bd2a6d37c29df212
parent 1b45fb809bf176caa6022379f54227ee1b653eaf
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sun, 14 Aug 2022 23:33:44 +0300
Add osmium-surplus
Diffstat:
2 files changed, 49 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -367,6 +367,7 @@ lib.makeScope newScope (
osm2geojson = callPackage ./osm/osm2geojson { };
osmcoastline = callPackage ./osm/osmcoastline { };
osmdbt = callPackage ./osm/osmdbt { };
+ osmium-surplus = callPackage ./osm/osmium-surplus { };
osmosis = callPackage ./osm/osmosis { };
osmwalkthrough = callPackage ./osm/osmwalkthrough { };
phyghtmap = callPackage ./osm/phyghtmap { };
diff --git a/pkgs/osm/osmium-surplus/default.nix b/pkgs/osm/osmium-surplus/default.nix
@@ -0,0 +1,48 @@
+{ lib
+, stdenv
+, fetchFromGitHub
+, cmake
+, boost
+, bzip2
+, expat
+, fmt
+, gdal
+, libosmium
+, protozero
+, sqlite
+, zlib
+}:
+
+stdenv.mkDerivation rec {
+ pname = "osmium-surplus";
+ version = "2022-08-13";
+
+ src = fetchFromGitHub {
+ owner = "osmcode";
+ repo = "osmium-surplus";
+ rev = "ac330247d75337e9381f6a3d21c8b851d5061ed9";
+ hash = "sha256-hvfeKUw/kMeja48WFTgmkAQhisCizLuLdoNh9yhNvWM=";
+ };
+
+ nativeBuildInputs = [ cmake ];
+
+ buildInputs = [
+ boost
+ bzip2
+ expat
+ fmt
+ gdal
+ libosmium
+ protozero
+ sqlite
+ zlib
+ ];
+
+ meta = with lib; {
+ description = "Collection of assorted small programs based on the Osmium framework";
+ homepage = "https://github.com/osmcode/osmium-surplus";
+ license = with licenses; [ gpl3Plus boost ];
+ maintainers = [ maintainers.sikmir ];
+ platforms = platforms.unix;
+ };
+}