commit 4a0a677001c2b96b1d0b93d6c00b2d2373d2884c
parent 1c3ccc6a8527777a0b64021e515d4cc2db91bfb1
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Sun, 12 Jul 2020 13:55:48 +0300
embox: enable on darwin
Diffstat:
2 files changed, 7 insertions(+), 5 deletions(-)
diff --git a/nix/sources.json b/nix/sources.json
@@ -100,15 +100,15 @@
"embox": {
"branch": "master",
"builtin": false,
- "date": "2020-02-04T15:17:46Z",
+ "date": "2020-07-09T10:51:08Z",
"description": "Modular and configurable OS for embedded applications",
"homepage": "http://embox.github.io",
"owner": "embox",
"repo": "embox",
- "rev": "ad5ed2947ae7ad68e6b0b0400c1a12d1a5114fa2",
- "sha256": "04rmqfrp8mv52q94q3yw4swn7vrl6jnzhly5fwr1977k77z619hn",
+ "rev": "69aab263f8eb45f78aebf6ffccf742a18b82c2b6",
+ "sha256": "1kka57s7qmc6x43lyy1vcmji8qvakbgmakh11y1i623h0r86a3vd",
"type": "tarball",
- "url": "https://github.com/embox/embox/archive/ad5ed2947ae7ad68e6b0b0400c1a12d1a5114fa2.tar.gz",
+ "url": "https://github.com/embox/embox/archive/69aab263f8eb45f78aebf6ffccf742a18b82c2b6.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
},
"foma": {
diff --git a/pkgs/embox/default.nix b/pkgs/embox/default.nix
@@ -52,6 +52,8 @@ stdenv.mkDerivation {
configurePhase = "make confload-${template}";
+ makeFlags = [ "HOSTCC=cc" ];
+
installPhase = ''
mkdir -p $out/bin
substitute ${runScript} $out/bin/run-embox --subst-var out
@@ -67,7 +69,7 @@ stdenv.mkDerivation {
inherit (sources.embox) description homepage;
license = licenses.bsd2;
maintainers = with maintainers; [ sikmir ];
- platforms = platforms.linux;
+ platforms = with platforms; linux ++ darwin;
skip.ci = true;
};
}