commit 3fd3c47895fd8c5b2fdba8e47a7e0c251b2ed14d
parent bf8879f482d87621211ad26e899f8fbe55bfbe27
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sat, 18 May 2024 15:15:34 +0400
Up
Diffstat:
1 file changed, 4 insertions(+), 6 deletions(-)
diff --git a/pkgs/geospatial/rio-tiler/default.nix b/pkgs/geospatial/rio-tiler/default.nix
@@ -1,15 +1,15 @@
-{ lib, stdenv, fetchFromGitHub, python3Packages, morecantile, pystac, color-operations }:
+{ lib, stdenv, fetchFromGitHub, python3Packages, morecantile, pystac, color-operations, rioxarray }:
python3Packages.buildPythonPackage rec {
pname = "rio-tiler";
- version = "6.5.0";
+ version = "6.6.1";
pyproject = true;
src = fetchFromGitHub {
owner = "cogeotiff";
repo = "rio-tiler";
rev = version;
- hash = "sha256-+9ThHahAFKwOzgaKkeAylMFu0Vtw12/tBiwSK9Dr4Sk=";
+ hash = "sha256-MR6kyoGM3uXt6JiIEfGcsmTmxqlLxUF9Wn+CFuK5LtQ=";
};
nativeBuildInputs = with python3Packages; [ hatchling ];
@@ -25,9 +25,7 @@ python3Packages.buildPythonPackage rec {
color-operations
];
- doCheck = false;
-
- nativeCheckInputs = with python3Packages; [ pytestCheckHook ];
+ nativeCheckInputs = with python3Packages; [ pytestCheckHook rioxarray ];
pythonImportsCheck = [ "rio_tiler" ];