commit 3cfaf1911afe00c0015f603f806b765db55de02a
parent 194fc0ed585abfc35e927b2644b7710ee0e4d5af
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sat, 22 Oct 2022 19:23:42 +0300
portolan: fix build
Diffstat:
2 files changed, 4 insertions(+), 2 deletions(-)
diff --git a/pkgs/development/python-modules/portolan/default.nix b/pkgs/development/python-modules/portolan/default.nix
@@ -11,6 +11,8 @@ python3Packages.buildPythonPackage rec {
hash = "sha256-zKloFO7uCLkqgayxC11JRfMpNxIR+UkT/Xabb9AH8To=";
};
+ propagatedBuildInputs = with python3Packages; [ setuptools ];
+
meta = with lib; {
description = "Convert between compass points and degrees";
inherit (src.meta) homepage;
diff --git a/pkgs/osm/map-machine/default.nix b/pkgs/osm/map-machine/default.nix
@@ -2,14 +2,14 @@
python3Packages.buildPythonApplication rec {
pname = "map-machine";
- version = "0.1.6";
+ version = "0.1.7";
disabled = python3Packages.pythonOlder "3.9";
src = fetchFromGitHub {
owner = "enzet";
repo = "map-machine";
rev = "v${version}";
- hash = "sha256-uVg9s1S9CXjBS8VdqZf+jDIR94pieD2nuoP94Jyce7U=";
+ hash = "sha256-kgf6COR6zK/PgFi4ivQeiRndgk41fHme4cPZTt+l6Xc=";
};
propagatedBuildInputs = with python3Packages; [