commit 3bbf3535b831246e104bc1149c640990c0c7e05c
parent 0fa9e8d4b9f652238b16ee28e7ed8cb138f78c5c
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Thu, 2 May 2024 17:09:30 +0400
Up
Diffstat:
6 files changed, 62 insertions(+), 25 deletions(-)
diff --git a/modules/home-manager/programs/vis.nix b/modules/home-manager/programs/vis.nix
@@ -0,0 +1,37 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+let
+ cfg = config.programs.vis;
+ configDir = "${config.xdg.configHome}/vis";
+in
+{
+ meta.maintainers = [ maintainers.sikmir ];
+
+ options.programs.vis = {
+ enable = mkEnableOption "A vim like editor";
+
+ package = mkOption {
+ default = pkgs.vis;
+ defaultText = literalExpression "pkgs.vis";
+ description = "vis package to install.";
+ type = types.package;
+ };
+ };
+
+ config = mkIf cfg.enable {
+ home.packages = [ cfg.package ];
+
+ home.file."${configDir}/visrc.lua".text = ''
+ -- load standard vis module, providing parts of the Lua API
+ require('vis')
+
+ vis.events.subscribe(vis.events.WIN_OPEN, function(win)
+ -- Your per window configuration options e.g.
+ vis:command('set number on')
+ vis:command('set tabwidth 4')
+ vis:command('set theme zenburn')
+ end)
+ '';
+ };
+}
diff --git a/pkgs/darwin/cudatext/bin.nix b/pkgs/darwin/cudatext/bin.nix
@@ -1,29 +1,29 @@
-{ lib, stdenv, fetchurl, _7zz, unzip, makeWrapper, cudatext }:
+{ lib, stdenv, fetchurl, _7zz, makeWrapper, cudatext }:
stdenv.mkDerivation (finalAttrs: {
pname = "cudatext-bin";
- version = "1.210.0.0";
+ version = "1.214.0.0";
src = {
"aarch64-darwin" = fetchurl {
- url = "mirror://sourceforge/cudatext/cudatext-macos-cocoa-aarch64-${finalAttrs.version}.dmg.zip";
- hash = "sha256-w7ypX5tYtAXaEaJgKXqhgH2ORw3yUSg0lOS3RG4lTbY=";
+ url = "mirror://sourceforge/cudatext/cudatext-macos-cocoa-aarch64-${finalAttrs.version}.dmg";
+ hash = "sha256-DU2QtKjPsHBw8hBb2t7cmYvUQ3UodgcW4Hp9kEyEzBI=";
};
"x86_64-darwin" = fetchurl {
- url = "mirror://sourceforge/cudatext/cudatext-macos-cocoa-amd64-${finalAttrs.version}.dmg.zip";
- hash = "sha256-9JQx1btljQ4/ybtEoBKQI00KOh9xp+7BEvuMhL2gKcw=";
+ url = "mirror://sourceforge/cudatext/cudatext-macos-cocoa-amd64-${finalAttrs.version}.dmg";
+ hash = "sha256-oGmUcPmnlqKn4mGVhbnFjM1FJ7H3uUg9Z7MKvt2By2Y=";
};
}.${stdenv.hostPlatform.system};
sourceRoot = ".";
# APFS format is unsupported by undmg
- nativeBuildInputs = [ _7zz unzip makeWrapper ];
+ nativeBuildInputs = [ _7zz makeWrapper ];
+ unpackCmd = "7zz x $curSrc";
installPhase = ''
runHook preInstall
- 7zz x *.dmg
mkdir -p $out/Applications
mv *.app $out/Applications
makeWrapper $out/{Applications/CudaText.app/Contents/MacOS,bin}/cudatext
diff --git a/pkgs/geospatial/bbox/Cargo.lock b/pkgs/geospatial/bbox/Cargo.lock
@@ -799,7 +799,7 @@ checksum = "8c3c1a368f70d6cf7302d78f8f7093da241fb8e8807c05cc9e51a125895a6d5b"
[[package]]
name = "bbox-asset-server"
-version = "0.5.0-beta1"
+version = "0.5.0"
dependencies = [
"actix-files",
"actix-web",
@@ -818,7 +818,7 @@ dependencies = [
[[package]]
name = "bbox-core"
-version = "0.5.0-beta1"
+version = "0.5.0"
dependencies = [
"actix-cors",
"actix-session",
@@ -829,6 +829,7 @@ dependencies = [
"clap",
"env_logger 0.9.3",
"figment",
+ "flate2",
"futures-core",
"fxhash",
"ignore",
@@ -856,7 +857,7 @@ dependencies = [
[[package]]
name = "bbox-feature-server"
-version = "0.5.0-beta1"
+version = "0.5.0"
dependencies = [
"actix-web",
"async-trait",
@@ -881,7 +882,7 @@ dependencies = [
[[package]]
name = "bbox-frontend"
-version = "0.5.0-beta1"
+version = "0.5.0"
dependencies = [
"actix-web",
"bbox-core",
@@ -897,7 +898,7 @@ dependencies = [
[[package]]
name = "bbox-map-server"
-version = "0.5.0-beta1"
+version = "0.5.0"
dependencies = [
"actix-web",
"async-process",
@@ -924,7 +925,7 @@ dependencies = [
[[package]]
name = "bbox-processes-server"
-version = "0.5.0-beta1"
+version = "0.5.0"
dependencies = [
"actix-files",
"actix-web",
@@ -969,7 +970,7 @@ dependencies = [
[[package]]
name = "bbox-server"
-version = "0.5.0-beta1"
+version = "0.5.0"
dependencies = [
"actix-service",
"actix-web",
@@ -994,7 +995,7 @@ dependencies = [
[[package]]
name = "bbox-tile-server"
-version = "0.5.0-beta1"
+version = "0.5.0"
dependencies = [
"actix-web",
"anyhow",
@@ -1008,7 +1009,6 @@ dependencies = [
"clap",
"crossbeam",
"dyn-clone",
- "flate2",
"futures",
"futures-util",
"geo-types",
diff --git a/pkgs/geospatial/bbox/default.nix b/pkgs/geospatial/bbox/default.nix
@@ -2,13 +2,13 @@
rustPlatform.buildRustPackage rec {
pname = "bbox";
- version = "0.5.0-beta1";
+ version = "0.5.0";
src = fetchFromGitHub {
owner = "bbox-services";
repo = "bbox";
rev = "v${version}";
- hash = "sha256-ffck1Ets1GyDPRXHjtugtibfHzpygJqJAdjTHYFzhnM=";
+ hash = "sha256-Vhzch4jnWtYQ2/x9tNGph8FDDxB1vRR9L9KVZf3Tha4=";
};
cargoLock = {
diff --git a/pkgs/suckless/imscript/default.nix b/pkgs/suckless/imscript/default.nix
@@ -13,13 +13,13 @@
stdenv.mkDerivation (finalAttrs: {
pname = "imscript";
- version = "0-unstable-2024-03-18";
+ version = "0-unstable-2024-04-30";
src = fetchFromSourcehut {
owner = "~coco";
repo = "imscript";
- rev = "a98d2ccbbba678ace9b35d6fe13bca772f1c0e60";
- hash = "sha256-+jaerzq9RnYry98xoVY6QSSQZH+rwVcn0mLwymw3ieM=";
+ rev = "15d60d8b6cc6ccf4ea3da8fb585a217449d368cc";
+ hash = "sha256-FZrIozaspU6gDXrhAFs5mU0jJEe94g9EfQ6ShKBDfRE=";
};
nativeBuildInputs = [ installShellFiles ];
diff --git a/pkgs/suckless/nextvi/default.nix b/pkgs/suckless/nextvi/default.nix
@@ -2,13 +2,13 @@
stdenv.mkDerivation (finalAttrs: {
pname = "nextvi";
- version = "0-unstable-2024-02-18";
+ version = "0-unstable-2024-04-29";
src = fetchFromGitHub {
owner = "kyx0r";
repo = "nextvi";
- rev = "31c890ef8adb0e729249ea818c283bf143b98e84";
- hash = "sha256-fo0k3zN+werG4WnhYwj9taWNstB8ypVknWagtYUWiHs=";
+ rev = "01f4dff99aab251ea502d17edcde5b16c0807977";
+ hash = "sha256-fKrlIgK5fCDh+WQyLpcF+k8NKOriJbGF3OVUwN/Ld78=";
};
buildPhase = ''