commit 3a5257aa7fc36e30d1a6ec350a1569b30e05c43f
parent 22e12518399923780342a60a6d710c4a75bd624c
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sun, 14 May 2023 23:56:10 +0400
Up
Diffstat:
3 files changed, 7 insertions(+), 4 deletions(-)
diff --git a/pkgs/geospatial/polyvectorization/default.nix b/pkgs/geospatial/polyvectorization/default.nix
@@ -1,4 +1,4 @@
-{ lib, stdenv, mkDerivation, fetchFromGitHub, cmake, boost165, eigen, opencv2 }:
+{ lib, stdenv, fetchFromGitHub, cmake, boost16x, eigen, opencv2, wrapQtAppsHook }:
stdenv.mkDerivation rec {
pname = "polyvectorization";
@@ -18,9 +18,9 @@ stdenv.mkDerivation rec {
--replace "#define WITH_GUI 1" "//#define WITH_GUI 1"
'';
- nativeBuildInputs = [ cmake ];
+ nativeBuildInputs = [ cmake wrapQtAppsHook ];
- buildInputs = [ boost165 eigen opencv2 ];
+ buildInputs = [ boost16x eigen opencv2 ];
NIX_CFLAGS_COMPILE = "-fpermissive";
@@ -36,6 +36,5 @@ stdenv.mkDerivation rec {
platforms = platforms.linux;
mainProgram = "polyvector_thing";
skip.ci = stdenv.isDarwin;
- broken = true;
};
}
diff --git a/pkgs/mqtt/emitter/default.nix b/pkgs/mqtt/emitter/default.nix
@@ -22,6 +22,8 @@ buildGoModule rec {
export HOME=$TMPDIR
'';
+ doCheck = false;
+
meta = with lib; {
description = "High performance, distributed and low latency publish-subscribe platform";
homepage = "https://emitter.io/";
diff --git a/pkgs/mqtt/mqtt-to-influxdb/default.nix b/pkgs/mqtt/mqtt-to-influxdb/default.nix
@@ -4,6 +4,7 @@
, cmake
, spdlog
, libyamlcpp
+, cpr
, cxxopts
, nlohmann_json
, influxdb-cxx
@@ -41,6 +42,7 @@ stdenv.mkDerivation (finalAttrs: {
buildInputs = [
spdlog
libyamlcpp
+ cpr
cxxopts
nlohmann_json
influxdb-cxx