commit 3948dddc6e865497cfa2ea833263f24712f7daab
parent e46fca650cc099eb1cd26b18636394467911a4b4
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Tue, 26 Nov 2024 19:29:50 +0400
Add exercisediary
Diffstat:
2 files changed, 33 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -350,6 +350,7 @@ lib.makeScope newScope (
dns-filter = callPackage ./misc/dns-filter { };
docker-reg-tool = callPackage ./misc/docker-reg-tool { };
docx2csv = callPackage ./misc/docx2csv { };
+ exercisediary = callPackage ./misc/exercisediary { };
ffs = callPackage ./misc/ffs { };
finalcut = callPackage ./misc/finalcut { };
freeopcua = callPackage ./misc/freeopcua { };
diff --git a/pkgs/misc/exercisediary/default.nix b/pkgs/misc/exercisediary/default.nix
@@ -0,0 +1,32 @@
+{
+ lib,
+ buildGoModule,
+ fetchFromGitHub,
+}:
+
+buildGoModule rec {
+ pname = "exercisediary";
+ version = "0.1.9";
+
+ src = fetchFromGitHub {
+ owner = "aceberg";
+ repo = "ExerciseDiary";
+ rev = version;
+ hash = "sha256-ekGluDuBF4Zb/XTxLRdztVg447x13uo24nNTBuVSfj8=";
+ };
+
+ vendorHash = "sha256-VKY5cvcjGfjOWa+GnMwdPOfTPOiwoXy0LB7kVD9l4kw=";
+
+ ldflags = [
+ "-s"
+ "-w"
+ ];
+
+ meta = {
+ description = "Workout diary with GitHub-style year visualization";
+ homepage = "https://github.com/aceberg/ExerciseDiary";
+ license = lib.licenses.mit;
+ mainProgram = "ExerciseDiary";
+ maintainers = [ lib.maintainers.sikmir ];
+ };
+}